Creating Gerberfiles


#1

Hello,
I would like to let produce a pcb board but when I made the gerber files I found some confused things. I made the gerber file for fsilk. How I can disable the value of the devices in the gerber files?

This are the gerberfiles they need:
elecrow.com
Top layer: pcbname.GTL
Bottom layer: pcbname.GBL
Solder Stop Mask top: pcbname.GTS
Solder Stop Mask Bottom: pcbname.GBS
Silk Top: pcbname.GTO
Silk Bottom: pcbname.GBO
NC Drill: pcbname.TXT
Mechanical layer : pcbname.GML

I changed the type from .gbr to gtl, gbl, …
But when I looked at the gerberfiles, the outline I made with Edge.Cuts does not exist.
How I can make the gerber for the holes and vias?


#2

In the dialog that pops up when you choose “Plot” from the menu, you’ll see various Options. One of them is “Plot footprint values.” Uncheck that box.

In that same dialog, there is a list of Layers in the design. Check the layers for which you want Gerbers generated.

Also, there is an option “exclude PCB edge layer from other layers.” In general, DO NOT check that, unless the fab doesn’t want the edge of the board on each layer.


#3

That would be the drill file.
Look at this tutorial: http://www.wayneandlayne.com/blog/2013/02/27/kicad-tutorial-gerber-file-generation/


#4

Thank you!

Yes I did that with Edges.Cuts but on the file I don’t see anything.
They say that at least one gerberfile should be the outline. But how I can put two gerberfiles together or can I get the outline on the top layer without changing the layer of the outline.

Is that the mechanical layer?

One dsub connector looks outside the outline. How I can delete these lines from the gerberfile because the pcb should not be greater than 10x10cm


#5

It is not. It is a file, that is created in another dialog. Please take a look at the tutorial, I posted the link to.


#6

There is written: “Exclude PCB edge layer from other layers”. Why?
I tried but on any layer there is the edgeCut


#7

How I can delete this connector silk out of the outline in the gerberfile without deleting it in pcbnew?


#8

The gerber plotter does only allow you do print silkscreen for ALL components or for NONE.
If you want the DB9 connector without silkscreen you have to edit the footprint with the footprint editor and switch those silkscreen lines to invisible or delete them.
That’s why most people - after a while - start to run their own libraries :wink:

As for the Edge Layer (Edge Cuts)… if you SELECT it, it will be in an EXTRA .GML or .GM1 file (that’s the mechanical layer or one of them if you have more than one). If you DESELECT the option it will be in all of the layers you have plotted (.GBT, .GBL, etc… pp) and NO extra mechanical layer file will be plotted.
From my own experience Elecrow is OK with the Edge Cuts being on a separate layer and that one being called .GBR.

The settings I used for exporting the gerbers for ELECROW - I did not have any non-plated-holes (NPTH) though:

[plots]
plot format: gerber

layers:
F.Cu
B.Cu
B.SilkS
F.SilkS
B.Mask
F.Mask
Edge.Cuts
B.Paste (for stencil)
F.Paste (for stencil)

options:
Exclude PCB edge layer from other layers

gerber options:
Use Protel filename extensions
Include extended attributes

default line width (mm):
0.1

format:
4.6 (mm)

[drill file]
drill units:
Millimeters

zeroes format:
Decimal format

drill map file format:
Gerber

drill file options:
none (DESELECT merging of PTH and NPTH)

drill origin:
Absolute