Creating a ground plane

Followed some video tutorials and my KiCad actions work as shown in the tutorials until the final click.
A zone marked with a crosshatch border appears. When I right click and select “Fill all zones” (Also tried “B”). The calculation/elapsed time dialog shows up for a split second and disappears with no error message and no ground plane. The zone parameters were set for and GNDREF. Are there any other settings that could prevent the appearance of a ground plane?

Not sure if this is your problem, but a zones don’t fill if there’s nothing for them to connect to within the zone outline. So you’ll need to make sure there’s a footprint pad with the same net as the zone inside the zone outline.

This +5V zone fills:

This one doesn’t:

Thank you. Yes I checked the name of the grounded pads. They have the same name as the chosen ground plane net.

I cannot agree with gkeeth: I can draw a completely isolated copper zone. But the final appearance is depending on the drawing selections (on the left side of the screen): you can enable and disable the filling of the copper planes. You have a variety of view options, which can be selected through the menu selection (view->drawing mode). You may check if this will solve your problem.
You can finally try the 3D view to check if the metal area is generated properly.

That is indeed another possibility, but still gkeeth is right. If a zone (or a part of it) does not reach a pad or a track as the same net in the zone settings then it will not fill, regardless of the settings in the left toolbar.

But we’re mostly flying blind here. Posting at least a screenshot may help.

If you can upload your project it will be easier to debug. Use File → Archive Project (from the project manager) to include all the useful files.

I checked in 6.0 before making that statement and I stand by it :slight_smile: Zones won’t fill if there’s no pad for them to connect with.

AFAIK that’s how KiCad has always worked.

I agree with the other possibilities in your comment, though.

Sorry guys, we have to refine the statement: zones fill when there is a pad with the same net inside the border or when they are not assigned to a net! Otherwise the filling is avoided and in some cases an error message is shown (6.0.9). When I draw two areas, one which can be filled, one which cannot be filled, an error message appears that there are unfilled areas. If only the zone which is not fillable is present, no error message appears! I belive one should think about this behaviour.

1 Like

Thank you. I have archived it. Do I just paste it here?
The drawing setting is set for displaying zones.
KiCad 6.0.8-1

In the “Copper Zone Properties” dialog the “no net” option will allow an isolated filled copper island.

I can confirm that a zone set to the net also fills.

Yes, you can use KiCad Project manager / File / Archive Project, then go to the saved location with a file browser and just drag the zipped file into the text area of a post on this forum.

Here is my project file
YOYO (406.4 KB)

Just tried No net option with No luck.

You do not have a proper PCB edge defined on Edge.Cuts. There is a “Non Copper Zone” on Edge.Cuts, but that is not a proper PCB outline.

When I draw a simple graphics rectangle (PCB outlines should be lines and arc segments and other simple graphic primitives), then the zone fills within that rectangle.

I’m not entirely sure why, but the latest KiCad apparently does not fill zones when there are no lines on Edge.Cuts. Is this a bug or a feature?

In my opinion this sentence about view options misleads the reader.
It should read: “you can enable and disable showing the filling of the copper planes”.
It does not affect the filling itself.

1 Like

Thank you very much. I made the edge cut on the wrong layer. Just drew a rectangle on the edge cut layer and got a very nice looking ground plane. Thanks for your time.

1 Like

Ah, I see, there is a (locked) rectangle on the User.Drawings layer. (but the layer was de-selected so it was not shown. You can select the rectange, press e to edit it’s properties, and then move it to the Edge.Cuts layer.

I’m not sure why you drew a “Non copper zone” on the Edge.Cuts layer.

I still do find it weird why a zone is not filled if there are no graphics on Edge.Cuts. Does anyone know?

If there are actually no graphics on Edge.Cuts, the zone will fill, as you expect.

The issue is that this design has some small circles on Edge.Cuts in the corners:

Once there’s anything on Edge.Cuts, KiCad will only fill within what it thinks is the board outline. You can see the issue clearly in the 3D viewer, KiCad sees this board as four very small circular PCBs:

@barrie I’m not sure why you have these Edge.Cuts circles around the pads, mounting holes maybe? Once you draw the correct board outline, these circles will be cut outs in the board, which may be what you want, but the through-hole pads inside the circles will not be present in the manufactured board.

Many thanks for your comments. This is my first attempt to make a PCB and see that I have made many mistakes, Yes the four corner vias are mounting holes and now realise I should have used mounting hole footprints. I think my biggest mistake is that I did not flip the DIP packages before routing. Consequently their orientation is wrong for a single layer PCB. I also used backside jumpers instead of zero ohm resistors. I can fix the mounting holes and jumpers but don’t think I can fix the Dip orientation without starting from scratch… unless … Is it possible to change the front copper to back copper? In any event, it has been a good learning experience. I intend to CNC route the PCB so I don’t have to be too concerned about manufacturability at this stage.

I was going to suggest this but you already figured that out :slight_smile:

This is not a bad first attempt at all.

1 Like