Crash in PCBNew 4.0.6 in Fedora 26 when moving trace in opengl


I’m wondering if anyone else has seen this problem before filing bug reports.

I just upgraded from Fedora 25 to 26 and am finding that PCBNew 4.0.6 crashes when in opengl mode and trying to move a trace. I can select a trace segment or entire net, delete and create new segments but if I select a segment and drag pcbnew instantly closes. It doesn’t seem to matter which track mode is enabled (route around, push & shove, etc).

I have 2 systems running F26, one with a geforce 950 running the nvidia drivers, and the other with intel graphics and both crash the same way.

Moving traces in the default (F9) view doesn’t crash. I haven’t encountered any other crashes in pcbnew or eeschema.

New projects, old projects, starting pcbnew stand alone, etc I’ve tried and all have the same result when trying to move an existing or new trace.

Starting pcbnew from commandline just gives a memory dump with no error.

I think that’s all I’ve seen so far. I certainly didn’t see this behavior when runnign 4.0.6 in Fedora 25, so I’m wondering if it has something to do with a dependency changing or some such.

Hi Starbird, before filing a bug report, check that this occurs in the nightly build as well. Many, many bugs have been fixed since 4.0.6 was released.

nightly is not comparable in any way to 4.0.x version any more. nightly is more like a pre alpha release for 5.x

If v4.0.7 really comes out within the next week it might be a good idea to wait for that. (This will probably be the last bugfix release though.)

If it is really related to dependencies than the guy packaging it should be made aware of this problem.