Crash! in eeschema

I am seeing some very strange behavior with V6.0 eeschema. Throughout the process of drawing a schematic it has acted strangely at times, but not repeatable. Holding down the mouse button too long seems to shift it into panning mode - instead of moving the intended object. Now, it is locked up. I can move the cursor within the drawing window, but it won’t move into the menus. Occasionally I can get the cursor to move to the other monitor, which is how I’m writing this. Since I can’t get to the menus, I can’t save my work. Both the center button and the right button put it into pan mode. I also have pcbnew open and I can see that by selecting it on the task bar, and it exhibits the same behavior. I’ll leave it open for now. Anyone have any ideas?

OS and version info please
Help - About KiCad - Copy Version Info

Windoze 10. KiCad 6.0

Help / About KiCad / Copy Version Info was a direct instruction.

It’s a function that is present in (almost?) every KiCad sub-program, and it copies much more info.
The complete version information is about 20 lines of text and includes information about some compiler settings and individual libraries used.
For example it also clarifies whether you are using KiCad V6.0.0 or V6.0.1

As an example, I’ll show you my complete version info:

Application: KiCad Schematic Editor

Version: 6.0.1-79c1e3a40b~116~ubuntu20.04.1, release build

	wxWidgets 3.0.4
	libcurl/7.68.0 OpenSSL/1.1.1f zlib/1.2.11 brotli/1.0.7 libidn2/2.2.0 libpsl/0.21.0 (+libidn2/2.2.0) libssh/0.9.3/openssl/zlib nghttp2/1.40.0 librtmp/2.3

Platform: Linux 5.13.0-27-generic x86_64, 64 bit, Little endian, wxGTK, xfce, x11

Build Info:
	Date: Jan 15 2022 20:26:22
	wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8) GTK+ 3.24
	Boost: 1.71.0
	OCC: 7.5.2
	Curl: 7.81.0
	ngspice: 31
	Compiler: GCC 9.3.0 with C++ ABI 1013

Build settings:

Now I’ve shown you mine and you should show me yours.
Or are you too shy?

1 Like

I know that, of course. But if you read my original post, I explained that I could not move the cursor outside the drawing window - therefore I cannot get to the Help or any other menu.

OK - Here’s part II.
Somehow, it started working again. I quickly saved what I was working on, and remembered that the last thing I did was open the program for assigning footprints to symbols. So I tried again. Same results. Locked up. Having saved my files, I shut it down with Task Manager. I will try again.

1 Like

Hello @bdh ,
Have you made sure you have converted all your libraries to 6. There has been some talk about old “project specific” libraries not converted that cause problems.

The original was drawn in 5.1.12 but then opened and subsequently saved in V6.0.0 There was one library that I had to convert.

But now - after I closed it with Task Manager I can’t reopen it. Several error messages.

Past my bedtime. I’ll deal with it tomorrow.

Thanks, everyone.


Make a bugreport (TopMenu->Help->Report Bug) and attach your project. You can mark it as confidential, if it’s a business thing.

Back at it again. I have submitted 2 crash reports on git and sent additional information and files. Current status is, my V6 schematic is missing a page. I have the V5 page converted to V6, which doesn’t help much. I had made significant changes when I went to V6, and created a number of new symbols. That drawing is apparently corrupt. If I try to select it in the tree view, I get an error that says it doesn’t appear to be a valid KiCad project file. The same with my V6 library.
But there are backups. In the tree view, the first listing is “New_Combiner-backups”. Clicking on the folder does nothing. The tree view does not show the individual backup files, but they are in the project directory. Is there any way to open these backups?

Thanks - bdh

Are your project files stored locally on your computer or on a cloud based storage i.e google drive or Dropbox.
My files are on google drive and when I moved to v6 I had a couple of anomalies with schematic files only part saving and the file not being complete. Not been able to reproduce it but I am wary and check the file size before closing now.

Everything is stored locally.

first: corresponding gitlab issue:

If you can’t recreate the crash anymore you should close the issue as gitlab should work as bugtracker, not as help forum.

now some steps to help you:

  1. work with a copy of your original directory (to not create/delete/destroy more files than currently)
  2. you have “New_Library” two times in your working directory, the old v5-version and a new v6-version. delete the old version.
  3. you have to tell kicad that you want to work with the new v6-library. Open the “new_combiner” project. goto Preferences–>Manage Symbol Libraries–>Project specific libraries. Observe: the entry for “New_library” has the Library-format setting "legacy. Delete this library-entry. "use waste-basket-icon). After that add a new entry for "“New_library”. Choose the new v6-library! Check that the filetype (Library format pulldown) is correct.Close Kicad.
  4. reopen Kicad and check library setting. If correct go ahead, otherwise try again.
  5. Open symbol-editor (from Kicad manager), look for library “New_library” and open it. You should see your 9 symbols. close symbol editor.
  6. you now have to convert your v5-file “RF-section.sch” into a v6-schematic. In Kicad-manager open project
  7. make sure this project points also to the v6-symbol-library!! (if necessary repeat step 3 for this project).
  8. open “RF_section.sch” with doubleclick. As stated in the gitlab issue you will get a warning because cache-file is missing. But with the library-file (steps 1…3+7) kicad takes the symbols from your library. Save schematic as v6-version. Close this project.
  9. open project, “New_combiner.kicad_pro”, all schematics should be there.
  10. make a copy and clear the project-directory: delete all old v5-files. (288.6 KB)

OK, I tried your suggestions.

  1. Done
  2. Besides New_Library.kicad.sym, which I believe is the V6 library, there is New_Library.bak, .bck, .dcm, and .lib. I deleted .lib, but I can recover it if it was the wrong one.
  3. There was no “legacy” entry. New_Library.kicad.sym was already in the list. I closed KiCad and reopened. It was unchanged.
  4. N/A
  5. Nope. New_Library shows up in the list, but there is nothing there.
  6. I had already done that. The result was what I had been working with - a V6 version of my V5 schematic with all the components missing.
  7. It does.
  8. I get no warning. I don’t recall seeing a mention of that in gitlab. Saved as V6 and closed.
  9. Nope. Nothing has changed.

Before I received these detailed notes from you, I had already begun to “start over”. I cleaned up the library symbols in New_Combiner.rescue.lib and started to place symbols in the schematic. It seemed to be working; I was regularly saving my work.

All of a sudden, my bug is back! I cannot move the cursor outside of the drawing window. Within the window I can draw or move symbols around, but I can’t move the cursor out of the window to access menus, so I can’t save.

Obviously this is frustrating. What now? Do I revert back to my original V5 project and finish it there?

Your comment about closing the issue in gitlab is questionable, since the bug still exists, although I have no idea how to reproduce it on command. It just happens…


regarding step 3: opening your original “New_combiner”-project and open “Preferences–>manage symbol libraries” the entry for “New_library” says “legacy” on my pc. This is the main reason the library shows no symbols and the conversions to v6 shows the symbols with the question marks.
How does it look on yours?

regarding the bug: if the crash is back than you are right, the issue could stay open. Albeit without a reproducible crash-sequence it will most likely not get fixed (how should the developers find the bug?)

last point: have you looked into my attached project ( There is the complete schematic (all 3 sheets) converted to v6. All unneeded files deleted. The “New_library” also converted to v6 (was already done from you in the original project) ans correctly integrated into the “project library”-settings.

My last attachement was not fully correct, so don’t play with v05, instead try this v16: (234.4 KB)

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.