Courtyards

How do I get the courtyard to fill in on my self-created footprints? I have drawn the outline around the part on the courtyard layer, but its not showing as filled in.

If you really want to Learn to use Kicad in an efficient way and save time (by not having to Post and Wait for answer’s), I recommend doing this for both PCB and Schematic…

Example: Create a Test PCB, place some items and other stuff and CLICK everything that’s clickable (and, Right-Click and double-Click them, too) and make Notes about what they do and how you did it…

First, why would you want the courtyard filled in?

Second, just like any other polygon, edit the polygon and select “Filled Shape.”

image

I wondered why the courtyards on library components that I used were filled in and then why components I created were not filled in. In any event, you have answered my question.

I have not noticed any footprint with filled shapes at Courtyard layer, but I didn’t looked through all footprint libraries.
Symbols have no courtyards, I think.

@bonsai Do you have an example of a default footprint with a filled-in courtyard?

None of the default footprints have a filled in courtyard.

It would not make sense to do it.

I have a feeling you’re confusing courtyard with something else.

It looks like KiCAD fills the courtyard in when placing the component from the library - see the snapshot below with the two power transistors. The cap doesn’t have a courtyard from what I can tell though.

image

Here’s another one

image

Mystery solved!

Is it because they are “Locked” ?

In image below, left one is locked, right one isn’t . . .
image

Thank you - that’s the real mystery solved! :+1:

1 Like