Could not find any symbols

Hi I just have started learning KiCad. I got very basic idea from online video tutorial.
I opened Eeschema window and then I tried to add a symbol. But the symbol selection window is empty. Can any one please help me how to get the symbols.

This generally looks like version 5 of kicad. I would assume you got a message about which library setup to create. I would assume you selected to create an empty library table. (My second guess is that you did not install libs and therefore the default was not available.)

Your screenshot does not look like windows and also not like mac so i assume linux here which means this will help: I installed KiCad 5 (under Linux) but there are no libraries. (The default option for sym lib table setup is disabled)

You could also take a look at Library management in KiCad version 5 (Not a click that do that tutorial but a lecture about proper library management.)

Thank you Rene_Poschl for your help.
My system running Linux Mint OS.
I tried deleting sym-lib-table and it gave me “what lib table should be imported” dialog. But the default global symbol option is disabled for me and I do not have a custom global symbol library to copy.

However I found that manually adding library is also OK for me. I am able to add symbol and footprint libraries. But I do not have any idea how to add 3D packages. Can you please help me regarding that?

Detailed lecture was already posted above (I suggest you read it).

TlDr: 3d models are not really managed. Footprints point directly to a file on the file system. The footprints of the official library use the path variable KISYS3DMOD to get them portable.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.