Copy paste inside symbol library editor

im trying to cut a symbol from a library using the symbol editor and paste the symbol to another library and its saying that no symbol was selected what is going on cause ive used this method before to manage symbol libraries

Welcome @franksterb92

The best way to move a symbol from one library to another is to use the “save as” function.

Using “symbol Editor”,
Find, then select the symbol to move,
right click, then, in the new window,
either change or leave alone the name,
scroll through the library list to find the receiving library,
highlight that new library and save.
all done.

ok thanks idk maybe its because im now using 6.0.4 maybe they changed it

“Save as” has always been there, even in 5.X.X
Copy / Paste works also, provided you highlight another symbol in the next library.
Highlighting the library name does not work for paste, so you cannot paste into an empty library.

another limitation: copy/paste works only in the same symbol-editor-instance, you can’t work with two different symbol-editors.

a picture showing the copy/paste-process.

This may be some bug introduced recently.

I have used the method described by mf_ibfeew in the past, and I just tried to do it again in V6.0.4 and it does not work for me right now.

I also get an info bar with No symbol selected when trying to paste.

However, when I paste into a text editor, then it does show a bunch of text that is very much like the copied schematic symbol. Both are from an AD1853.

My pictures above were freshly taken with a v6.0.4. I have now looked again - the paste only works if the RMB-click to invoke the context-menu is done on an already existing library-symbol (see jmk). right-clicking on the library-name gives the “no symbol selected”-info-bar message.

Agree, however I cannot comment on previous versions using copy / paste as I had never bothered with copy / paste, always using “save as”.
I only tried copy / paste this time because of OPs comment.

Ah, indeed. It works for me too now.

I first tried to copy some symbol into an ezisting library, did not work and I thought it may have something to do with write permissions, so I created a new library and tried to copy a symbol into it, which also did not work.

The last thing that does work is:

  1. Create a library (Here: 0000_asdf)
  2. Create some symbol in it (Here: asdf)
  3. Select some other symbol in another library (Here 74xx / 74HC00)
  4. Select the asdf symbol in the 0000_asdf library.
  5. Paste the 74HC00.

I find this behavior quite un-intuitive and maybe this should be reported on gitlab.
Unfortunately I’m a bit too fuzzy now to check if it’s already among those 1451 open issues.

but I put it down to being a CAD program… 10 ways to do anything if you look hard enough… and some ways are good and some not so good. :slightly_smiling_face:

I find this behavior quite un-intuitive and maybe this should be reported on gitlab.
Unfortunately I’m a bit too fuzzy now to check if it’s already among those 2000 open issues.

At least the “can’t paste into empty library”-issue is already there with symbol editor: Copy/Paste symbol into empty library not working (#11053) · Issues · KiCad / KiCad Source Code / kicad · GitLab.
Maybe it gets attention for v7.

Ah-hem, 1,490 at the moment.
Reporters of issues must be resting.
We all really need to find more issues to keep the Devs. occupied. Can’t have them sitting around eating pizzas and watching TV, eh, @mf_ibfeew :grinning:

1 Like

Just tried 6.99, and the answer is … not yet.

yea thats why cause the libs were empty ok yea after doing it with save as is better thanks for the advice i honestly just hate the yellow filled symbols so im editing the libraires lol

Look what can be done in 6.99 (the future 7)


Real circus stuff! :grin: :grin: :grin:

I’m waiting for the tie-in to ngspice where a symbol will go smoky coloured when the component goes pear-shaped during simulation. :stuck_out_tongue_winking_eye:

It’s actually not so far-fetched. One of those online simulators would show a blown light bulb if the current rating was exceeded IIRC. :wink:

I just gave this a image on gitlab.

I’m guessing this got a V7.0 tag because it was originally reported as a regression in V6.99, although I think this behavior was already present in KiCad V5. If y’all give the issue a few more thumbs up on gitlab it probably gets bumped to V6.0.5 or something near that.

Thanks for finding the issue on Gitlab.

@ JMK,
(With space, not a real ping)
Sometimes it shows as “2k” to me on gitlab, although when going deeper it indeed shows a more accurate number. I updated my post to 1451, Which is still a lot to search through.
I also counted 10 pages back (20 issues per page) while sorted on “last updated” in “closed issues” and I got to 2022-03-17. So that is more then 14 issue’s per day. Which is quite an amazing number.
(It’s also completely bogus, since the effort needed to fix a single issue can be anything between 2 minutes and hundredths of development hours).

Done, although I will still continue using “save as”.

It wasn’t supposed to be a serious comment. I fully understand that your abacus is probably due for a service and lubrication. :slightly_smiling_face:

Interestingly, I was making colorful gates in response to the OP’s remark and found a minor inconsistency issue:

That was number 1450 open… Maybe the Devs. will need more pizza to give them strength to continue their quest. :roll_eyes:.

i honestly just hate the yellow filled symbols so im editing the libraires lol

@franksterb92 : If you don’t like the filled symbols at all you are free to adapt your colour-theme:
open any schematic, open Preferences–>Preferences–>schematic-editor–>colors–> row “symbol body fills”
Doubleclick the displayed color at the “symbol body fills”-entry, move the opacity-slider == 0. (memorize the old value in case you want the old setting back).
Et voila → all symbols show a transparent background.

edited thanks to @jmk

The issue on gitlab has already been closed with commit d9668938b917bb620ce6f121728c2564a5ad6f6

Which means that when KiCad V6.0.5 is available, it should work again as intended.