Copper zones not plotting?

I haven’t ki’d any cads for a while, busy with something else, but now I can’t make it do something simple I know I’ve done a dozen times:

When I plot my pcb to a gerber, none of the filled zones are included? Huh?

A ground plane in PCB New. (Yea, I know it’s not very neat.)

Is missing from grbview.

What have I overlooked?

Can you please post a screenshot of the zone settings and a view of the layout with it filled?

Properties of the zone in the bottom left.

The whole board. It’s to be home-etched with one side. Figured on a one-evening project till it wouldn’t put the zones in the gerber.

The zone GNDREF is not filled.
With legacy canvas (F9) and right click, fill the zone. There is another option “Fill or refill all zones”.

I think it is something else, maybe a bug, definitely a feature…

In this case, I think the zone does not capture enough of the net to be filled. A track passing through does not “trigger” the fill. I was able to reproduce the problem in v4.0.6.

Zone doesn’t fill (yes I did select “FIll Zone”!)

Just drag the left edge a bit (I changed absolutely nothing else, honest :slight_smile:

I found the same behaviour in both Default and OpenGL canvasses.


Zones only fill when they have a connection to their Net and yours looks totally isolated

1 Like

“Fill Zone” Oh! I knew I was overlooking something. Thanks!

I was forgetting to type “B.” - the responsive cheat-sheet :wink: