Copper traces not appearing in 3D

I did my first ATMega simple Pcb design.
Net counts and Pads affected are Ok.
Up and bottom copper traces are seen correct in Gerber files,
Also Silk and so on.
But copper traces are not seen as copper in the 3D view, just some points almost not clearly visible.
Where am I wrong ?
Thanks a lot,

One observation: ATMega328 in the SCH does not show Pin 22, shows clearly the other 27 pins.
Footprint shows it !

which kicad version are you using?
If it is the nightly version, you may have your solder mask opaque, change it on the solder mask color options, where you can reset to defaults.

It should, and if it doesn’t then you should fix it. Pin 22 should be

Hello, Thanks for the fast answers.

My version goes attached at the end.

I played with colors with no result.
Concerning pin 22, I connected it to GND as per Atmel datasheet.
Anyway. Kicad accepted the wiring at pcb level, but still does not show my connection in sch.
Thank you !

Application: KiCad
Version: (5.1.9)-1, release build
wxWidgets 3.0.5
libcurl/7.71.0 OpenSSL/1.1.1g (Schannel) zlib/1.2.11 brotli/1.0.7 libidn2/2.3.0 libpsl/0.21.0 (+libidn2/2.3.0) libssh2/1.9.0 nghttp2/1.41.0
Platform: Windows 7 (build 7601, Service Pack 1), 64-bit edition, 64 bit, Little endian, wxMSW
Build Info:
wxWidgets: 3.0.5 (wchar_t,wx containers,compatible with 2.8)
Boost: 1.73.0
OpenCASCADE Community Edition: 6.9.1
Curl: 7.71.0
Compiler: GCC 10.2.0 with C++ ABI 1014
Build settings:

One more info:

I did a quick RC circuit with one trace up and the other in bottom layer.
Same environment displays the top one in red and the bottom one in green.
Strange behaviour.

Thank you,

These are the technical colors. You may want to switch it to Realistic Render or reset the default options

Thanks Kammutierspule

I tested both options but no way.

I will document my job, end start a fresh copy from scratch to see what happens.
Is very quick, except to draw the traces.

Thanks again for all your help,

You should “fix” the issue.
Click on the schematic symbol and press “ctrl + e”.
On the right menu bar there is an option to “Add pins to symbol”; add the pin 22 to your symbol.

This allows for ERC and DRC to work correctly.

If you’re talking about the DIP-28 version of ATmega328, then pin 22 is present in the default library.

It’s hidden and stacked over pin 8 as per KLC4.3:

Power supply pins must be stacked unless the datasheet specifies the need for decoupling capacitors on every pin.

Enabling “Show hidden pins” (image) will prove it’s there:


Solved !

Fresh graphics adapter driver solved the issue.
HP Laptop had a Windows(MS) driver for the graphics adapter.
I uninstalled it and replaced with the original Intel Graphics adapter driver and all the design is accurately represented in 3D.

Thanks a lot for all of you for the quick help,
Have a nice week end !

That is strange… Do you still have a screen shot of the bug?

Hello Kammutierspule

Unfortunately I cleaned my files after solving the problem,
But I changed step by step different approaches, and only when I uninstalled MS Graphic Driver and replaced it with Intel Graphic Driver, the 3D representation came alive !

Have a nice week and, and thanks for your help.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.