Copper pour only partially visible in 3D view?


#1

So I’ve been pretty impressed at the quality of 3D renders, but I came across a little anomaly I was wondering if anyone else had seen. Only part of the ground pour on my top copper layer is showing up on the 3D view. What’s odd is that I’d either expect it to be completely missing, or all there, not just part of it. Here’s the 3D view:

…and here’s the view from pcbnew showing the filled zone:

…This is just a minor quirk, since the Gerbers appear correct:


#2

What is your kicad version? What is your operating system? What are your settings?


#3

Is the ‘Show Zone Filling’ Option selected?


#4

Kicad v4.0.7, Windows 7. What settings in particular should I report on? The 3D Viewer settings? The issues seems to exist under both the “realistic” rendering mode, and the not “realistic” mode. But I do notice some odd lines that look to be where the edges of the fill are when in non-“realistic” mode on the 3D Viewer:

Thanks,

Greg


#5

you may need to click on the refresh buttons


#6

Yes, “Show Zone Filling” is enabled. And toggling that, does turn off the filled zones that are shown correctly. Here are some of the other rendering parameters:


#7

Unfortunately neither of the refresh buttons makes a difference.


#8

Looks like the “Show Holes in Zones” setting is the culprit. Turning that off renders the zones properly:


3D Viewer will not show ground fill when option "Show holes in zones" is selected
#9

Bug report time :wink:
https://bugs.launchpad.net/kicad
please include the about info from kicad