Copper pour not filling up

Hi, I am using KiCad 5.1. I started to use KiCad since yesterday. The project I created has a schematic, a library (symbol and footprint) and the pcb. I was able to place the components, but there are multiple copper pours in both layers of the board and I am unable to get a few of them getting filled, when I give the Redraw command. The priorities of the copper pours are set to different values, because the pours are overlapping. The nets are:


The pours on top layer are:

The priorities are:
VDC-: 0
VDC+: 3
The VDC- and MODULE- pours get filled up when I press redraw and the VDC- pour withdraws from the area of the higher priority MODULE- and VDC+ pours. However, the VDC+ pour is not filling up for some reason. Am I missing some setting here? I can share the board file if required for help.

My first thought is that is has something to do with the zone priorities.

Uploading the board would make it a lot easier to diagnose your problems.
I do not work much with overlapping zones myself, and always forget whether low, or high priority zones are drawn first. Have you tried modifying the priorities of your zones?

Thank you for the quick reply. Where do I upload the board? Here is a dropbox link:

Here is a screenshot of the unfilled copper zone/pour:

Oops, I was too fast. I think my post below is gibberish.

I found your board on dropbox, and changed the priority of that zone from “3” to “0” and now it looks like:

Note that the zone is drawn now, but with a big clearance around the pads.
Clearances are different settings, and can be adjusted for components, pads, zones, and I’m not sure which is what and priorities with those. I do not use them enough in complicated situations to be familiar with them on that level.

Delete the graphic polygons from U1 footprint and the zones are filled without problems.

Select your zone, and press “e” for edit.
Then set the clearance value of that zone to a small value. I set it to 1mm. (with a zone priority of “5”. and this draws it as a separate zone.

The Clearance of that zone was set to 3.175mm, which is bigger then the width of the zone, and therefore no copper was shown on your PCB.

Also note that your zone does seem to be drawn, but it only shows a clearance in the surrounding zone, but it’s hard to see exactly because it concides with the fat yellow line on your screenshot.

Hi Paul,
The clearance zone is set to 125 mil, but does not have thermal connections, but a solid connection to any pad of same net. The copper pours on the part are there because it is a part with flat bus bar terminals with 3 threaded holes per terminal and the pcb will mount on that part. The holes are for mechanical securing and electrical connection, whereas the copper pours are for making contact with the terminals. I used copper pours and was intending to expose the copper by using an identical pour on solder mask layer.

This is because I previously used Eagle and Eagle does not let you have SMD pads and then put through hole pads on top of those SMD pads.

What is the best way to do this in KiCad?

Additionally, there is a VDC+ plane on the bottom layer that is also acting up. Could you please see that too? Thank you so much for your help.

Here is the link to my library. I put pads on the part, instead of polygons.
The part under consideration is named CAS325M12HM2_POS_NEG_PAD_BOTH_LAYER
However, one of the terminals (N) needs to have SMD pad only on bottom layer, while the other terminal § needs SMD pads on both layers.

You answered your own question:

In this case ensure you use a normal smd rectangle pad and also make sure the pads zone connection is set to “from parent” (Is the default when adding a new smd pad.)

I’ve been looking a bit at your other zone’s on the bottom.

I see 2 square zones on top of each other, which are a copper zone and a cutout on the solder mask. It seems more logical to draw a custom footprint for that, with an SMD pad of the size you want.

Then there is also a big zone on the bottom, connected to the VDC+ net, that does not get filled. In KiCad areas of Zones only get filled if they can be connected to a net, and because the VDC+ net is surrounded by … (I don’t know what exactly) the zone does not get filled. If you draw a track from a VDC+ pad into the zone, it gets filled, and if you change the net name of the big zone to one of the other nets it also gets filled. This is done on purpose to prevent unconnected copper area’s in zones, for example if an area is unreachable because it is surrounded by tracks of other net’s.

Sometimes you have to press “B” to re-calculate the zone boundaries to update on your screen.

I made a bit of a mess of your drawing, but from what I can see it all works as it should:

To have the zone fill properly it must be able to reach the center of pads connected to it, and it seems that your row of purple SMD pads is being overlapped by some crearance from something around the big green thing on the bottom.

Edit, followup:
I was having some trouble in getting an overview of what I was looking at and I just discovered that you’ve drawn a big custom footprint (See screenshot from the footprint editor below) and that footprint has polygons in it. This is a bit of a new and not fully supported thing in KiCad.

I think it’s better to replace those polygons with (big?) SMD pad’s. It is a bit unclear for me what your intention of this thing is (It’s me, I’m having focus and concentration issues).

Hi Rene,
I did that in the library. But the part created has a weird layout.

When I view the created footprint in 3D, it shows exposed copper on top/front side for pad labeled P on silkscreen, but no holes on top side. It shows holes on the bottom side for pad P (numbered 1), but no exposed copper on that side. I put one SMD pad on each side and 3 through hole pads, so this should be showing exposed copper on both sides with holes on both sides, correct?

Similarly, for the pad labeled N, it shows holes on the top side and no exposed copper, which is expected (no SMD pad on top side for this one). But on the bottom side, there is exposed copper, but holes are not visible. Why would that happen? Could you please help?

Hi Paul, please see my post above. I have recreated the footprint (link posted) with SMD pads instead of pours. There is some issue with the footprint though, as mentioned in the post. Please see if you an comment.

I do not have a clear goal of what you’re trying to draw here.
I also do not know the changes between the footprint’s you’ve made and I find KiCad’s way of first having to add libraries to the library table before being able to get a footprint from a library a bit of a nuisance. Combine that with deleting your big PN thing and not knowing whether I’ve re inserted the old one from some cache or the new one from dropbox makes it all a bit too much for me at the moment.

I’ve separated the zones on your big P-N footprint a bit. It seems that on the “P” side you drew a polygon on top and on the bottom, which overlap copper with diffent pads, and on the “N” side you have a polygon on the bottom that overlaps with 3 other pads.

This is a very weird thing to do in KiCad.
If you want to overlap stuff in a footprint, then you should use pads with the same name. And as long as you have multiple pads with the same name, then KiCad simply treats it as a single pad.

When reviewing a footprint simply use the import function of the footprint editor instead of going via a library that you manually add. (At least for reviewing a single footprint.)

The silver thing that covers the pad in the 3d viewer is solderpaste.

And you also have made a mistake for the left pad “P” that you have on the bottom. It still has the top layers for mask and paste selected. (To properly move a pad to the bottom side simply use the flip function hotkey f while you add it. This exchanges all top layers with bottom layers and vice versa.)

Hi Rene,
I rectified the layer assignment. My question is this:
If I have an SMD pad and then I put a through hole pad on that SMD pad, is there a way for KiCAD to show the hole in 3D view, rather than only solid solder paste?

A couple ideas:

  1. Turn off the solder paste rendering in the 3D Display Options: 2019-04-16%2018_20_46-3D%20Display%20Options
  2. For that SMT pad turn off the paste layer:

In reality, if you are using solder paste stencils that are fabricated from the output of KiCad, then unless you turn off the solder paste for the SMT pad, paste will cover the hole. And if the hole is large enough (and not filled), during reflow the hole may rob your SMT pad of solder paste giving you a bad solder job.

I honestly haven’t been following this thread close enough to know your design intent.

1 Like

The intent is to have a pad that will have an exposed copper pad to connect some flexible copper bus bar and the holes are to mechanically secure the part to the board, while also giving some electrical contact. Soldering would not be done using any stencils, this would be a manual soldering job. So yeah, for 3D viewing as you said, I can turn off the paste layers and that will give me the view I am looking for.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.