Copper pour not filling in small zones, no matter the clearance

I have a copper zone that is fairly small and does not want to fill. I know that I could create a wide copper track instead, or a graphic polygon on the F.Cu layer, but this is a script-converted board and I would like to know if there is a setting to force this copper region to fill instead of doing hacky replacements.

I tried to set the clearance to zero, the priority high, etc. but none worked. Any ideas?Thanks in advance.

I attach here the PCB. Zone is in coordinates 35.5mm, -44.7mm on F.Cu (438.6 KB)

I suspect that neighbouring things interfere with with the zones apility to connect to the center of the pad. Try to draw a short trace from the pad into the zone. If that does not work then you might have assigned the wrong net (use the highlight tool to see if the pads and the zone light up and are therefore on the same net).

Generally i advice against using unnamed nets for copper zones. Any change to the schematic could change the netname and therefore result in your zone being unconnected. So i suggest you add a local label to any net that you want to be represented as a zone.

1 Like

Thanks for the quick reply.

I can draw a track without problems. The copper zone is assigned to that same net than both two pads, ass it can be seen in my screenshot above, it is N46, the same as the two pads. Also in the schematic. But it still does not fill.

Is it possible you view zones in outline mode? (view dialog or left toolbar)
Also don’t forget to refill (shortcut b) after any change

Here with highlight:

Yes, I refilled after every change.

It can’t be the visualization mode, because other zones in the same board are filled, see on the right:

Can you share the file?

It is attached in my first post. Thanks.

If I run DRC, i get some warnings, but i can get rid of several of them by adding some priority to the zones. But it still does not fill.

There are different causes for the zones not to get filled.

Mainly zone clearances and kepouts.
But you have other nets that are completely surrounded by other nets and don’t have a way to “jump” to the zone.

Try also with zone priorities.

Yep, I had tried already with zone priorities, see post above.
Also, the zone does not need to jump any zone. There is a track connecting them, so that cannot be the issue.

It looks like it is in the middle of a keepout copper pour zone


Thanks, good point. I assume that there is no priority level for keepout areas?

No priority level that I know of.
Your zones will need to cover the pad centres as well to remove the ratsnest wires


In the future, it would be nice for keepout areas to have a checkbox to ‘allow inside islands’. So to say, just to prevent copper pour from outside boundary.

What I ended up doing was converting the zone to a graphic polygon on F.Cu plus a track with the proper net.

I managed to get your zone to fill without modifying it’s boundaries.

The steps taken:

  1. Open the board poster earlier.
  2. Hide all copper layers except (just for visibility).
  3. Select the small zone, press e for edit, set priority to 100.
  4. Select the “keepout area”. Change from “copper” to “via’s”.
  5. KiCad says it re-calculates zones, but this does not show a difference.
  6. Press b to re-calculate zones again. Now the small zone fills.

As far as I’m concerned I’m happy, because I do not see a (real) bug.
Maybe the small zone should have been filled after step 5 and step 6. should not be needed. But I think it’s too small an issue to make a ticket on gitlab for this.

1 Like

thanks so much for the workaround!

It’s not really a workaround.
It is just a confirmation that zones in keepout area’s do not get filled.

A possible workaround is to convert the imported data not to zones, but to Pads, or to modify the outline of the keepout zone.

The most logical “real” solution is to give keepout area’s a priority in exactly the same way as the zone’s have priority now. But from what I understand from your gitlab issue that Idea was rejected, and I do not understand why. The reasons given seem false.

It is an option of the kepout zone


Thanks. Yes, what I was doing before was to convert those small zones to graphic filled polygons on the F.Cu area. This worked well, sometimes there was an additional keepout inside this small zone, so I had to add this extra keepout as a hole in the polygon. So right now I managed to solve all issues with many workarounds. But yes, definitely keepout priority would be nice.

@ferdymercury In this case you should use “Zone cutout” instead of “Keepout area”. These two things are similar in some aspects, but the “Zone cutout” allows other zone fills inside. To add a cutout, rightclick Zones edge and select Zone > Add zone cutout