Copper Pour and Margin in Kicad 8

I drew some holes in the cutout layer for my NPT mounting holes then I drew some larger circles around the holes in the margin layer to keep copper pours away from my mounting holes. The copper pours didn’t respect the margin boundaries though. What should I have done to keep area fills away from my mounting holes?

I haven’t seen this workflow before, do you need a lot of clearance due to high potentials ? or perhaps something else but I usually just select ‘Mounting Pads’ from the Kicad libary or maybe one of my own and let the clearances sort themselves out or changing them in the zone manager. I have never considered holes as requiring ‘2 layers’ before, could you show a picture and give the version number please :smiley:

File–>Board setup–>Design rules–>constraints–>Copper–>Copper to edge clearance must be greater than zero.

Maybe additionally required: from zone properties dialog–>parameter “remove islands” set to always

The first suggestion kinda gave me the effect I wanted. It pulled the copper pour further away from my mounting holes. It also affected some other parts of the board negatively. I wasn’t able to find the dialog in your 2nd suggestion.

Thanks. If I had done this from the start I could’ve got what I wanted but now I have to redo all my ground planes and I’m leaning toward just leaving it.

I need more clearance than I’ve got. I may have to file the holes a little for location adjustment. I was depending on the margin circles to keep my copper pours away from the holes. The copper pours didn’t violate the edge cuts layer. Why the margin layer?

Make a footprint for your mounting holes, with the NPTH in the footprint.

In pad properties you can set a pad clearance which will push back the pour to whatever you’d like.

1 Like

@jksgvb : you should at least try the advice from mousey and squiggle, maybe that workflow suits you. After trying you can better decide which solution is more to your liking.

But you could also remain at your current solution (circles at edge.cuts + surrounding margin layer). I use both approaches and both work well and both have advantages/disadvantages.
So don’t feel yourself pushed into the “use mounting holes” footprint workflow.

I wasn’t able to find the dialog in your 2nd suggestion.

doubleclick zone → zone properties dialog → bottom right edge of zone properties dialog: remove islands setting.
depending on this setting the inner part of your margin circle (between margin circle and edge cuts circle) may (or may not) also be filled with copper.

1 Like

Ahh this! In zone properties I change the “remove islands” setting from the default “never” to “below area limit” and then leave “minimum island size” to the default 10mm squared and viola: I get the copper pours to respect the margin circles without messing up other parts of my board. Wierdly, it does this on all layers even though I only set that property on one ground plane. I’ll take it even though I have no idea what the settings mean.

1 Like