Copper planes do not extend to keepout zones of pads

Hello there,

at the moment i’m routing tracks and copper planes on my pcb. Hower the copper planes do not extend to the keepout zones of the pads (like shown on the foto).

Does anyone have an idea how to fix this? Because this does not really look good.


Best regards

This foto shows the properties of the copper planes.

Your screenshot looks perfectly fine.

What do you mean with:

Please elaborate.

What i mean is that the copper plane does not match the edge of the keepout area (blue arrow) at the pads. There is a gap of some mil between (green arrow).

This picture is from a friends layout. Here the copper plane matches exactly the keepout area.
I checked the properties, but there are identical.

The thin red lines are clearance settings. (These are in Pcbnew / File / Board Setup / Design Rules / Net Classes)

The bigger clearances in your first screenshot are from the Thermal Relief setting of the zone itself.

These are two different things. The clearances act between different nets, (and zones) while the Thermal Reliefs work between pads and zones of a single net.

1 Like

Thanks, now it works

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.