Copper Island without thermal reliefs is desired


#1

Hi Community,

I am attempting to dutifully follow the layout guidelines for a TI buck converter, a small section of which is shown in the diagram below;
TI_layout

Also shown is my attempt to create a copper island in KiCad to mimic this layout;

However, I cannot seem to remove the thermal reliefs, despite trying various options from within the “Copper Zone Properties” menu such as changing the “Pad Connection” to “Solid” or “None”, messing around with the clearance settings / priority levels. I’m grasping at straws at this point.

Does anyone know how to remove the thermal relief’s?

Many thanks,
Tim.


#2

If changing the zone properties does not do the trick, check in the footprint and pad properties. But also remember to refill the zone after each change as it might not get updated otherwise. (Refill is done with shortcut B or run DRC)


#3

Thanks Rene … bingo. Changing the local pad properties did the trick;