Copper Fill w/ No Connection & Solid Connection

Hi everyone… I seem to be having issues with calling out certain pads to be solid connection after doing a copper fill on a zone with “no connection” in pcbnew. If I edit the pad and select the tab “Local Clearance and Settings” and change the pad connection to “Solid” and then refill All zones, it does not appear to have any effect… all pads in the zone are still “no connection”. I’m guessing there must be some global setting over-riding it but would also believe a specific-pad edit would over-ride all globals… Any help is appreciated!

What do you mean with:

Do your zone properties look like this?

I tested it with my nightly builds version.
Seems ok. (What version do you use?)

If i leave the pin settings normal i don’t get a connection.

If i change the pin to solid it connects.

Pins 3 and 4 to solid, all other pins are with from parent footprint.

My second test:
In the footprint settings one can also select the zone connect type.

I changed the right footprint to solid.

I get the following result:

@Rene_Poschl thanks for the help, I tried doing exactly that (both your first and second method), still with no luck… I made a screencast below just trying to do it around a single footprint, maybe I’m missing something?

Note that I don’t have nets, I merely am duplicating an existing board that isn’t complex so have just freehanded the board in PCBnew… I wouldn’t think this is the reason why I’m having difficulty however. I’m using version 4.0.5.

Without that the zone can’t ‘attach’ to pads as it can’t belong to that net…
You need a netlist for this to work.

Found a workaround, I edited project_name.kicad_pcb and added the lines

(net 0 “”)
(net 1 “GND”)
(net 2 “15V”)

(or whatever be the case), and then manually edited the pads “Net Name” to be one of the nets above, and then did the fill and all works perfect. It looks like pcbnew cleans up the file and removes any unused net names when saved, that’s the only trippy part of my backdoor.

1 Like