Copper fill violates keep out area

Hi Folks,

Copper fill is violating Keepout boundary by adding unspecified chamfer at the corners which go into the keepout area. See below. Can anyone advise how I can remove this besides defining an over-sized keepout area. I am using V5.1.2.

Thank you all.

I strongly recommend that you make backups of you projects and update to 5.1.9
5.1.2 is two years old and there have been a lot of bug fixes since then in the stable branch.

1 Like

Many thanks davidsrsb. I didn’t want to fix it if it ain’t broke. I guess it is now. I’ll try your suggestion.

I also recommend to upgrade.
Minor version updates are very low risk and mostly bug fixes.

It’s also free!

That said, What does your Zone properties look like?
In V5.1.9 there is a setting for: Corner smoothing which can be set to chamfer.

There are also two different ways to make a cutout in a zone, about which I wrote an hour or so ago in this post:

[Edit] typo: V5.1.8 -> V5.1.9 Must have been fuzzy to type an old version number.

Corner smoothing is set to none. That’s why I said in my post that KiCad is “adding unspecified chamfer”.

If it still persists after you update to V5.1.9, can you then report back with a skeleton project with that area of the PCB.
If you do so I’ll have a look at what’s going on.

Update to V5.1.9 has fixed the problem. Many thanks.

1 Like

It fixes that problem but has introduced another. When I use “Edit Text & Graphic Properties…” to change comp ref sizes, KiCad changes all Fab %R references too but changed their layer from Fab to Silk layer so I end with every component having two visible refs on the silk layer! See image. Has anyone come across this and have a fix how I can change them back not one by one?
image

This are the settings that I use to change the reference sizes and it works as “expected”:

You should change the filter and the action layer to “B.SilkS” for the bottom part.

The Edit Text and Graphic Properties is a quite powerful dialog that can change lots of things in one go.

Do you suspect a bug, or your own user error?

When working with (and especially when getting to know) such tools, frequent backups are highly recommended, but if you had those, you probably would not ask :slight_smile:

There is always the option to just exit Pcbnew without saving.

Maybe [Ctrl + Z] works with the Edit Text and Graphic Properties dialog.

Thank you one and all for the suggestions. The Edit Text and Graphic Properties form is indeed a powerful tool to use very carefully. With great powers come great responsibilities! All sorted.:+1: