Copper fill should cover the external area

Hi everyone, im doing a new design and i need my copper fill inside another to cover its outer area


as i demonstrated here, i need the lines from the zone going the direction as shown with the red lines
Keepout purple pwr2
Keepout purple pwr3
I have a copper fill covering the whole board as VCC3V3, and i need to make a kind of keepout zone where i will put another copper fills inside that keepout.

Any suggestion?

If you edit the properties of a zone you can set a “priority level”:

Zones with higher priority levels are drawn first, and other zones keep their distance according to normal clearance rules.

1 Like

Priorities is probably the way to go, but it’s also possible to make a hole in a zone: while a zone is selected, open the context menu -> Zones -> Add a Zone Cutout.

1 Like

Already tried those, wont work.

Here is an example of the already finished board, so when i click on the zone outline on the board outline, the one inside also gets highlighted. And the outlines aren’t connected.

I don’t understand your use case.

Based on this I would say either priorities or cutouts would work. The screenshots don’t help me to understand what you want.

1 Like

This is what i want.

It is impossible to see what you have made from a screenshot.

To get your “artists impression” into KiCad, you can draw two different zones, the big yellow one and the smaller green one, and then give the green zone a higher priority.

The “zone outline which gets highlighted when i press the outline on the board outline” part is not drawn in KiCad. That zone boundary is calculated with B according to clearance settings.

You also have a relatively complex PCB with lots of zones. It’s probably a good idea to experiment a bit with zones and zone priorities on a simple PCB.

Attached is a PCB with some simple zones. The highlighted zone is defined by the PCB outline (and the pentagon around the PCB). This way it is immediately clear upon inspection if for example someting goes wrong with gerber generation). In the upper left corner there is a small keepout area, and just for fun I drew a triangular zone with a higher priority in the center of the PCB.

When the zones are shown not filled, there is no indication of the clearance between the “pentagon” and the “triangle” zones:

LoPower4.kicad_pcb (212.8 KB)

do you require them to be as unaligned as that? or can you accept basically a clearance ring?

Below is what you can do with zone priorities. you see how they are isolated but are comparable shapes ( the inner is a 1v2 to an FPGA core and the surrounding is 3v3 to interfaces).

The shape doesn’t have to be made out of right angles, you can use whatever polygon you want BUT the zone clearance will mean it follows the shape. If you want the larger voids you cartoon shows, you could manage that via selective keepout zones

I don’t know where your problem is. Here’s a zone with a cutout and another zone inside it:

Thanks guys, i managed to do it. It happened i have been mistaking “Cutout” zones with “Keepout” zones…turns out i’ve never used cutouts before. Just realized those two have a different application.

Greetings :smiley:

2 Likes