Consistent crash while changing between projects

some plug-ins do not allow kicad to close completely, it continues to hang in processes … Known error

Seems similar to this thread from m852:

Is it already known which plugin(s) are related to this problem?

Have you made a bug report for it in the last 20 months? As long as bugs don’t get reported, they won’t get fixed either. There is a strong correlation between those two.
With also the last remark of Billy_B in that thread there are now at least 4 people reporting this on this user forum.

I don’t use plugins much, and don’t have this problem myself.

Yes, it is known … But it’s not clear where to report? I usually calculate the deletion method by 1 and check … The second problem is that the plugin, after being removed from the manager, can remain in another folder and hang in processes, and in this case only the complete deletion of the folder where it is located helps (from the post above description) … On the one hand, this is a problem of the plugin developer, on the other hand, deleting the plugin from the manager does not always help, and here is the problem of kicad
Another point on the example of the kibom plugin that continues to work and does not close, this behavior only happens on win64 on Linux, everything works fine As a result, there is not only a dependence on the plugin, but also on the platform

Are you sure that everything is ok with your plugins? I can’t trace the dependency, for some reason some of the plugins work fine and the other honor does not allow the program to close completely … somehow it turns out selectively and on which side of the problem it’s hard to say …

I use Bouni’s JLCPCB plugin and the Replicate Layout plugin.

the main thing here is to determine which side of the problem, if from the plugin side, then a question to the author if the problem is on the kicad side, then open the error on gitlab
Replication Layout really hangs after closing…

No plug-ins and no problems here.

Application: KiCad x86_64 on x86_64

Version: 7.0.7-7.0.7~ubuntu22.04.1, release build

wxWidgets 3.2.1
FreeType 2.11.1
HarfBuzz 6.0.0
FontConfig 2.13.1
libcurl/7.81.0 OpenSSL/3.0.2 zlib/1.2.11 brotli/1.0.9 zstd/1.4.8 libidn2/2.3.2 libpsl/0.21.0 (+libidn2/2.3.2) libssh/0.9.6/openssl/zlib nghttp2/1.43.0 librtmp/2.3 OpenLDAP/2.5.16

Platform: Linux Mint 21.1, 64 bit, Little endian, wxGTK, cinnamon, x11

Build Info:
Date: Aug 13 2023 23:14:49
wxWidgets: 3.2.1 (wchar_t,wx containers) GTK+ 3.24
Boost: 1.74.0
OCC: 7.5.2
Curl: 7.88.1
ngspice: 38
Compiler: GCC 11.4.0 with C++ ABI 1016

Build settings:

I think it must be the replicate layout. I have installed it only recently and the crash is also relative new to me. 1 + 1 = probable cause.

I do have the Replicate Layout plugin, (and just used it too) and it does not crash, so that makes the JLCPCB plugin suspicious.

The instructions from the first post are a bit vague, so here is what I did:

  1. Open a KiCad project.
  2. Open Schematic and PCB editors from the project manager.
  3. Moved some footprints, ran the Replicate Layout plugin.
  4. Exit the schematic editor, save and exit the PCB editor.
  5. Then: KiCad Project manager / File / Open / Open Project and select a random other project to open it.
  6. Open the Schematic and PCB editors in that other project.

I uninstalled the replicate layout plugin, on work PC problem → gone. (for now, I’ll keep checking)
I reinstalled, problem is still → gone.
I’ll try my other machine tonigh. Though this one also had the problem.

I wrote that I have no problem with the Replicate Layout plugin, and suspected the JLCPCB plugin to be the culprit. (I have not installed that one).

I knew well what you wrote. But I suspected the other plugin… because my problems started about the same time that I installed the plugin. I have used the the JLCPCB plugin much longer than that. And now it seems that the layout replicate plugin may be the cause

It could be that one of the previous versions of Replicate Layout plugin had a bug, but has been fixed.

As a this plugin author I was not a aware of any such a bug, so if there was and if it was fixed it was purely coincidental.

Anyhow I think that we also need to know plugins and their version which are installed when the crash occurs.

1 Like

I also think plugins should run in some kind of sandbox so they can’t crash KiCad at all. I imagine there are libraries for such things, but all my programming knowledge is on microcontroller level and I don’t know much about PC stuff.

1.9.0 After closing the kiсad continues to hang in the background processes … win 10 kicad 7.0 .7

You do not have them, and others may not have them on Linux

SOLVED! At least my Crashing problem is solved…

I removed all of my plugins and added them back one-by-one with enough testiing between each move.

It turns out that the plugins that caused my crashing was due to bad Indentation of pcb Refresh!!! Just needed to indent to correct position and Bingo, no more crashing.

I’m not completely finished going through them (just did the one’s I often use so, if it happens again, I’ll re-post…

As of now my plugins work without Crashing when re-opening PCB and Projects/PCB’s.
My plugins include:

  • embedded action code
  • running external App’s
  • tweaking Footprints, layers
  • calculations, text replacement, graphic tweaks…
  • track and pad tweaks…
  • calling wx, Tkinter Graphics, windows and Message Pop-Up’s…

I went through all of my Plugins and found only the one mentioned having Refresh with incorrect indentation. After fixing that, and going throung many Usage-Tests, Open, Close, Open-other Projects and challenging my plugins to Crash, No Problems :smiley:. So, conclude it was my Oversight at not seeing the indentation of Refresh in one plugin was not consistent with my other plugins, even though that plugin worked.


Did the exact same, same result here as well. Crashes goodbye (onto the next crash :stuck_out_tongue: )

In current testing/nightlies, a check has been added to prevent crashes in Python plugins like BlackCoffee’s (trying to use the pcbnew module before Run).


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.