Connector Pad too close to pad

Hello, I’m working on my first KiCad and it is a simple board that has one Samtech QTH connector (QTH-030-XX-X-D-A) and one 2x16 2.54mm header. I have downloaded the symbol and footprint from and have placed it on the Pcbnew. When I run the DRC I get two errors on pin 58 and 60 on the QTH. This is a small smt and the pads are very close. There must be a configuration that I need set so that the pad to pad trace is above some min value.

** Drc report for F:\myKiCad\Break_Out_Board\Breakout_proj\Breakout_proj.kicad_pcb **
** Created on **

** Found 1 DRC errors **
ErrType(19): Pad too close to pad
@(171.083 mm, 98.594 mm): Pad 58 of J1 on F.Cu and others
@(171.583 mm, 98.594 mm): Pad 60 of J1 on F.Cu and others

** Found 0 unconnected pads **

** End of Report **

I have uploaded the error message. The QTH series is a 0.50 mm (.0197") pitch low profile.

Can anyone help me please.
Thank you

I’ve looked at the some other posts and have tried playing with the General Net Class Clearance but when I change the value it then complains about the Diff Pair Width.

Any ideas?

QTH-030-XX-X-D-A.kicad_mod (6.9 KB) QTH-030-XX-X-D-A.lib (2.8 KB)

I’ve uploaded the symbol and foot print of the QTH connector. Hopefully that can help others help me.
Thank you

I turned off the F Mask. May make things easier to see.


I’ve been playing with the Board Setup and Net Classes. I changed the Default Clearance to .01 and I see the thin red line around the pad get smaller. However, pad 60 the thin line around the pad did not get smaller.

Hello, well I solved the problem with the help of this forum. I noticed that when I changed the clearance at the Board Setup>Net Classes > Clearance that pad 60 was not being updated. I simply clicked on pad60 and wend to the Clearance Tab and changed it to 0.1.

I ran a DRC and did not get any errors. But I went back it changed it to 0.2 and ran DRC and there were no problems.