Connection grid

How do I get rid of the warning wire end off connection grid in Kicad 8 I have 800+ warnings If I can’t solve t

select rmc → align items to grid

This is one of the more important ERC-checks in the schematic editor.

So just disabling this check (in schematic setup–>Electrical rules–>violation severity–>symbol pin or wire off connection grid) can be done, but is not recommended.

Instead make sure that the setting for this ERC check is correct and equal to your used grid: schematic setup–>General–>Formatting–>Connections–>Connection grid.

ans as claudio wrote: If your wires are really off grid you have to move all of them onto a grid position. use the command “Align items to grid” from the RMB-click context menu.