Connecting wire on top layer removes the one on the bottom - can I stop this?


#1

At the edge of my PCB I have 3 connectors (conn_01_xx type). I want all pins of the same number to connect together. I place the 3 connectors next to each other (0.1" spacing). I have completed the board and I am just checking front and back. I note that connector 2 and 3 have all pins wired on the top and bottom layers. But connector 1 and 2 have connections only on the back or front layers. Haha, I must have forgotten to make the connection. So I select wire and link row 1 to 2 for pin 3 (for example) on the top layer because the bottom layer was already connected. Now I see that although the top layer is now connected the connection on the bottom layer had gone away.
I think I have seen this behaviour elsewhere, when connecting using a larger (or smaller) size trace, the old one is automatically deleted.
Is there a way to temporarily switch this off?
Why has connector 2 and 3 correctly accepted the wire on top and bottom layers?
:thinking:
NOTE: this is my 5th layout and I am still learning. I am using Kicad PCBnew 4.06.!
regards…
–migry

wiring%20problem|568x500


#2

Why? Do you have some specific reason to use such an old version? It’s unmaintained (no bugfixes), inferior in features and you get less help for it because most active forum writers use 5.1.

5.1 has an option for it:
image


#3

Dear @eelik thank you for the quick, clear and detailed reply.

Do you have some specific reason to use such an old version?

Well, simply it works, and it’s the old adage “if it’s not broken don’t fix it”.
I probably installed it quite some time ago, and only recently have I been designing PCBs and getting them fabbed. So far I have been more than impressed/happy with V4 despite a few quirks.

A friend who had been using V4 with some success upgraded to V5 and had lots of problems, such as random crashes, or the 3d viewer not working. This was on a very modern Win10 PC. His experience put me off moving to V5. He still hasn’t solved his crash problem and runs Kicad V5 on a remote PC (as this remote PC works correctly). I know this as he demoed adding ground planes only a couple of days ago and I was surprised at his need to use a remote PC. BTW he has completely uninstalled and re-installed, but the problems have not gone away. He has posted a question elsewhere in this forum.

Nevertheless I will take your suggestion on board.

Quick question - can I have both V4 and V5 installed at the same time on the same PC?

regards…
–migry

BTW after playing around I have found a fix/workaround. If I try to connect between pin ‘n’ on connector 1 and 2 it rips up the track on the other layer. If I connect between connector 3 and connector 1, then the new connection appears and the tracks on the other layer are not ripped up.


#4

Yes, although it’s unnecessarily complicated. See General topics in the FAQ (Start Here) Frequently Asked Questions.


#5

If he had a problems then I suppose he didn’t uninstalled completely.
KiCad saves user configuration in user catalog and new version tries to work according to it.
If there is info telling new version to use 3D directory which was just completely uninstalled than I’m not surprised KiCad has a problems to use it.
At my PC (Windows 7) that directory is: C:\Users\Piotr\AppData\Roaming\kicad
When I changed 4.0.7 to 5.0 I just deleted that directory before installing 5.0.
Then installing next V5 versions I don’t delete this directory at one PC (to have it working with my libraraies) and delete at second (to work with KiCad libraries).

For me one argument is enough to switch to V5 - via stitching is solved. When you put via at zone (or anything else having its net) that via automatically gets zone net and don’t lost it. You not need to connect all that vias with tracks to make tham not lost their net.
Of course there are many others improvements, but I really don’t remember V4 to enumerate them (I have done only one test PCB using 4.0.7 and it was enough long time ago).

There are some bugs in 5.1.4, but they don’t disturb me enough to make me install last 5.1.x nightly in which most of them are fixed. I hope shortly will be 5.1.5 to switch to it.


#6

I have a guess that the problems where with converting projects to v5. Not with the installation. And the update does not clear up the footprint lib table.

@migry Before updating to v5 read these:

And remember that 3d model stuff will not work for old projects unless you point to the 3d models of old projects (3d models are not included in the project so the old footprints point to the old v4 models which where handled differently)