Connect type 2 errors


#1

I’m getting connect type 2 errors all over the place. Its just screw terminals, resistors and transistor driven relays.all components are from the default library. when I placed wires it seems to have a hard time recognizing where the connection is supposed to be. I go to the error and place a green dot connection symbol. It doesn’t help. I place a green dot anywhere it lets me in the vicinity of the connection and it still doesn’t help. I’m new to KiCad but I have used others. Any idea why I’m having this issue?
thanks


#2

Check to see if your grid setting is 25 mills. The library components are generally made on that grid and it causes problems if other sizes are used when placing components.

Set grid to 25 mills.
You might have to remove a previously placed component and the put it back on.


#3

The library components should have a minimum grid size of 50 mils, if not 100 mils. If you see any on 25 mils, let us know and they can be fixed.

I would advise using a grid size of 50 mils for schematic editing, and design components to 100 mil grid if possible. Unfortunately if you have components off-grid, there is not an easy way to realign them, though I did recently write a script to do that.


#4

Good try but no help. I did have the grid set to 0.1 in. I reset to 25 mils
deleted the terminal,wires and net labels. 're-placed the screw terminal,
re-drew the short wires, added net labels and got the same result. Tried
adding green dots, no help.

Some success,! I turned off the grid after placing, then placed wires.
That’s working. I have to re do most of it but it does seem to work

Thanks for helping.


#5

It works with some but there’s still many I can’t get connected. Grid on,
grid off all combinations. They just won’t hook up.

The terminal size is ,.050


#6

The grid cannot be turned off. It can be hidden/shown but it is still there.

Set the grid to 50 mils. The dots of the grid will help you check the components out of grid.


#7

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.