Confusion between kicad and libraries's version


#1

Hello everybody,
Firstly, thank you for this great software. I’m using it from few years and I love last new upgrades.
I saw information on the version 5 libraries and I want know if we can use them with the kicad version 4.0.7, the last stable on debian-backports.

I’ve not really found info on it, only :

Requirements

The files packaged here are intended for KiCad version 5 or nightly builds that support the schematic library version 2.4 or newer.

Regards,

gilou


#2

Are you using version 5 or a nightly build? If not then they are probably problematic :wink:


More detailed answer:
The library file version understood by kicad 4.0.x is 2.3.

The problem with symbols is that kicad 4 does not display the content of the description file (datasheet, tags, description) if the library is version 2.4 (Kicad does not throw any error message.)

Library file format version 2.4 allows for longer pin number strings.
As the official libs should not contain symbols that use the new features you could simply change the version information in the file header. (There is no guarantee that this works)


For footprints the problem is that the new lib has footprints that use rounded rectangle or polygon pads. There is a script that deletes such footprints from the library. So you could use a reduced library in kicad 4.0.7. More details see: How can i install a specific version of the footprint library? (Information about how to use version 5 libs in version 4 is in the second post of that thread.)


#3

Hello,
thanks a lot for reply.
Actually I using the version 4.0.7 and because I teaching to students how design PCB on kicad, I prefer use stable version. I was confused with the read-only status on kicad-library repo and by the version 5 news.

I will continue to teach on V4 and wait for the V5 for a next time.
Thank you for the information sharing.
gilou


#4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.