Confusion about which library to contribute to


#1

Hi!
I recently did (at least tried to) create and contribute some footprints and
therefore cloned the kicad-footprints repo.

One of the footprints was as DC/DC converter… so I assumed to
add this to directory: “Converters_DCDC.pretty”!?

However when opening the footprint editor I always get a:
"Converters_DCDC_ACDC" library.

Question: Why is footprint editor opening a different lib?

Is there anything I need to change in my settings in order to “get it right”?
Right now I’m creating the footprint via import/export to the directory with the
footprints…

PS: I’m using KiCAD (5.0.2)-1


#2

Might it be that you had kicad version 4 installed in the past? I had KiCad 4 installed previosly. Now i updated to v5. Now i have some problems with the library setup


#3

Yes… this was it! Solved! :slight_smile:

Did I miss something during upgrade or is this default behaviour?
(If not: Maybe installation should take care of this in future versions?)