Confused by Version descrepacy

What version am I really?

I go to KiCAD dot ORG and it says KiCAD is on version 5.1.10. But here’s what my updated KiCad shows in Help:

Application: KiCad

Version: 5.99.0-unknown-ac933d4e83~109~ubuntu20.04.1, release build

Libraries:
wxWidgets 3.0.5
libcurl/7.74.0 OpenSSL/1.1.1j zlib/1.2.11 brotli/1.0.9 libidn2/2.3.0 libpsl/0.21.0 (+libidn2/2.3.0) libssh/0.9.5/openssl/zlib nghttp2/1.43.0 librtmp/2.3

Platform: Linux 5.11.0-25-generic x86_64, 64 bit, Little endian, wxGTK, mate, x11

Build Info:
Date: Aug 4 2021 18:53:57
wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8) GTK+ 3.24
Boost: 1.71.0
OCC: 7.3.0
Curl: 7.68.0
ngspice: 31
Compiler: GCC 9.3.0 with C++ ABI 1013


So everything I show on my computer says I’m on version 5.99, but KiCAD org says it’s only up to version 5.1.10. So is the main internet page 0.8 versions behind, or am I a time traveler and 0.8 versions ahead?

Yes, I see that the Platform is Linux 5.11.0 but that doesn’t match what the .org says either. Nor does it match what I’m showing…5.99.0.

So could someone clear up this minor irritation for me? Thanks! (I do like the thought of being a time traveler though).

Short answer:
Version 5.99 is a nightly version and is not an official release version.

5.1.x are the stable “release” versions.

5.99 is the unstable, nightly development version of what will be 6.0.

5.99 has a lot of nice new features, but also some caveats. See Is it a good idea to use a nightly build version?

Oh, yeah, nightly version. I wasn’t aware it was a ‘push’ update. I thought we had to request it. I should check my computers settings for that.

What is your platform / how did you install kicad? Nightlies shouldn’t be installed unless you specifically go out of your way to install them.

The instructions for both stable and nightly builds on ubuntu are here: https://www.kicad.org/download/ubuntu/

My son informs me that he installed the upgrades when I wasn’t looking. So that mystery is solved. Platform is mentioned in my first post. Used ‘Term’ to install KiCad.

Both the stable KiCad V5.1.x and KiCad-nightly V5.99 can be installed (and used) at the same time on a single computer.

You have to be careful though with KiCad-nightly V5.99. Once you save a project in it, it can no longer be opened by older versions of KiCad.

I’m pleased with the look and feel of the 5.99 version and haven’t had a problem with my older projects popping right up when opened.

Do have a problem where none of the thousands of library components that should be available show up when I try to add anything to a schematic but I’ve yet to do a search about it. Likely just a path issue.

It is probably a path error, but it is possible that you have the “Lite” Nightly, which is basically just the binaries

It’s also possible that when your son installed the nightly, he picked the option to create a default (empty) library table rather than to use the default library table containing the built-in libraries.

Since @Jim_HiTek is on Linux, I assume this is not the case – you have to try fairly hard to install KiCad without the libraries on Linux.

If you want to try resetting your configuration, you can re-do the “first start” dialogs, one of which will give you the option to install the default global library tables. Try this to see if it fixes your library configuration.

To do so, you have to delete your configuration directory while KiCad is not running (you can also make a backup of this directory or rename it).

Since you’re on Linux, this will be located at ~/.config/kicad/5.99. If you browse to ~/.config/kicad in your file manager or terminal, you should find the 5.99 directory. You can rename it, for example to 5.99_backup, which will cause KiCad to re-create it the next time you run it.

Opps. Should have come back to mention that I did find that I was just to timid with the libraries and KiCad’s conversion routine. Once I let KiCad guide me when I tried to open an older schematic, and went with the instructions instead of balking at it, I find that everything is there! Brilliant!

I would really like to see a conversion from OrCAD to KiCad though. I have hundreds of OrCAD schematics and PCBs I’d like to convert.

Yes, I am on Ubuntu v21.10. KiCad works slick, no big problems now. Couple of minor issues (posted on a different thread) but whatever, maybe v6.0 will fix them.

Concerning OrCAD, you might be interested in
https://forum.kicad.info/t/need-for-orcad-allegro-importer/31194
But there is still a lot more work to do until schematics or layouts can be imported.