Components with fabrication attribute component "Other" not displayed in 3D-viewer

Again, before going to the bug tracker: is this by design?

What is this “other”?

Ok, got me :-). Fabrication attribute->Component “Other”.

Short answer:
Yes, I think it’s by design.

Long answer:
Where did you find this “Fabrication Attribute, Other”?
Which KiCad version?

In the Current KiCad V5 if you edit the properties of a footprint in Pcbnew, it has Fabrication Attributes “Through Hole”, “Surface mount” and “Virtual”, and the “Virtual” Footprints are not shown in the BOM and have no 3D model. They are used for stuff like mounting holes, edge connectors and Net-Ties.

In KiCad V5.99 (Going to be V6 some day, hopefully soon), there is indeed a “Fabrication Attribute” for “Other” in the Footprint Properties in Pcbnew, and it has more options than in KiCad V5. In KiCad V5.99 it has options to exclude the Footprint from the schematic, pos. file, or BOM separately.

I set the Fabrication attributes of a random Footprint to “Other” to make the screenshot, and therefore crossed the “Library link” out, because that combination does not make sense.

Well, it is in V5.99 as shown in your screenshot. I’m using nightlies all the time and eventually forget to mention the version. But my OP was whether components with the fab attribute “other” are to be displayed in the 3d viewer by design. Currently they are not. Wanted to check in here before I open a bug that gets classified “as designed” and wastes the dev’s time.

My first best guess is that if [x] Exclude from position files is checked, that would also mean that the 3D viewer does not show 3D model even if it is defined in the Footprint. But it’s just a guess, I have not done much with V5.99 yet.

Instead of guessing I also experimented a bit.
I first opened an existing V5.99 project, looked at it in the 3D viewer to verify that a big THT capacitor was visible, and then changed the Fabrication Attributes to “other” and later also checked “[x] Exclude from position files”. The capacitor stays visible. Also changed the other 2 checkboxes and closed and opened the 3D viewer and the capacitor stays visible.

I do remember a library issue with the 3D models. Somewhere there was a bad link to the directory with 3D models and KiCad-nigtly V5.99 could not show any of the models until I fixed that library path link.

@paulvdh Strange. Here the component does not show if fab attribute is set to “Other”. Changing that to “SMD” or “Through hole”, it is displayed. I can play that back and forth all the time.
No 3d model path issue there.
Let’s call it a day. I’ll ask the devs about it in the mailing list and see. It is not that important, just wanted to know. Thanks for your time and involvement.

The whole “Fabrication attributes” section may be misleading. I think the actual fabrication attributes, SMD/THT/Other are for gerber generation which will become gerber attributes. The other options are probably for KiCad internal use. If I’m right the Other option shouldn’t trigger 3D because it doesn’t tell anything about the footprint. Actually it could be interpreted to mean that it’s only for a 3D model, not for a land pattern!

Makes sense.
But then, shouldn’t there be a visibility checkbox in 3dviewer preferences->display options for fab attribute “other” components, like for SMD/THT?

“Not in schematic” is handy for logos, graphics or mounting holes you just place directly in the board, avoiding PCB/schematic mismatch DRC errors. There is no point in having copperless holes in the schematic. Mounting holes with pads are a different story
“Exclude from position files”: usecase unclear to me. First step towards variants?
“Exclude from BOM”: if there are e.g. mounting holes with pads connected to a net (mostly GND) in the schematic you want to exclude that from BOM.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.