Components not snapping to grid

Hi Experts,
I need to edit an existing circuit in EEschema but I find that the components are not snapping to the grid anymore and thus also no wiring between them can be made.

I have attached the file herewith, please refer to three components/labels, etc. not snapping in the segment (column 3, Row C). the rest i.e. the old stuff - still looks good and was not touched today.

Also, another strange behaviour which I have observed today is that if I try to select a new grid value, then, instead of a table of some 20 or more grid options (in normal KiCad operation), only 7 or 8 grid options are shown to select from. I have not seen this behaviour in any other KiCad projects I did yet.

Unfortunately, I can’t take a screenshot of this behaviour because that “short grid option list” disappears in the process.

Probably the problem would be solved if the display of the full list of grid options could be restored. Is there some way to “reset” the grid?
Kindly advise. Thanks.
Best regardsKiCad Ver. Info.pdf (69.3 KB) 201005 Timing & ACPR Logic.sch (41.7 KB) 201005 Timing & ACPR Logic-cache.lib (14.0 KB)

You write about Eeschema. I have 7 grid options there and don’t remember had any more ever (I use 5.1.7).
These are 100, 50 (the only one I use), 25, 10, 5, 2, 1.
To position refs and values I use Ctrl+Shift key combination so never change grid to any other than 50.

1 Like

After reading your message I checked and compared EEschema and Pcbnew.
You are absolutely right, the Eeschema has only 7 grid options.

But what could be the possible cause of components not snapping to grid?
Any suggestion that I could try, please?
Thanks and best regards

Could try this. Open a copy of your drawing (for safety) and right click / Grid / Grid: 50.00 mils. Add those three components again. In screenshot I am on Grid: 50.00mils and symbols from my library and a wire snap fine to drawing you uploaded. Switched to another grid value and inserting they don’t line up. Worth a try, nothing to lose.

Hi Mendy,
Thanks for your efforts in suggesting a solution to my problem. You are right setting the grid to 50 solves the problem. In fact, this is also what piotr had also mentioned in his reply earlier only that I didn’t read it properly.
So, I would like to thank you and of course also Piotr for providing a solution.

My proposal to KiCad designers would be to generate a warning about the risk of non-snapping components if the user tries to change it Eeschema. The user can still decide for himself what he/she wants to do.
This warning could be very similar to KICad warning in pcbnew if the user attempts to edit a footprint that has previously been locked.

Best regards

I think there has been some discussion about the ability to toggle between 2 different grid settings: 50 or 100 for placing symbols and wires, and something smaller for positioning reference designations and other text for example.

Plausible idea, would need to have user set grid options but think it is highly improbable that they will divert developer resources to it being heavy into V6
development and they have the right click method available. Possibly in V6 after release.
Here are some examples for Starter99 of your usage. Do use the change grid method and on occasion edit text and add spaces in front of text to move.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.