Components do not "snap to grid" (oh, not again!)


#1

Hi
I downloaded a full kicad project from the github repo held by a friend of mine (as we need to work together on this very same project)

… and when I tried to modify some aspects of the design (on EEschema, I insist), I discovered that abolutely NO component or wire was snapping to grid. In fact, it looks like the whole grid was shifted by half the value of the grid step.

It’s definitely not a “bad component design”, as all component are comming from the official kicad repo. No exotic stuff, just resitors, op amp, caps etc.

Could it be a compatibility problem between two different releases of Kicad? did someone stumbled on the same problem ? is there an “secret magic order” to change the origin point of the grid ?

Thanks for reading
Marc


#2

More likely that the designer of that project did use a smaller grid setting then you are using now.


#3

In general, it’s best to use the same version if you are collaborating. In this case, I can’t think of any changes that affect the grid in eeschema.

No, in eeschema the grid origin is always (0,0).


#4

Hi
Thanks Bobc
You’re confirming what I understood about the way eeschema is dealing with it’s grid step.
I think the versionning could effectly be the origin of the problem. I’m using the current 4.0.7, and my friend uses a 4.0.0 rc2. (and don’t want to change as long as he could find a migration solution for his former projects…)

I’m affraid their is nos real solution.
Thanks again
Marc


#5

Hi Rene
there is no way to change the grid setting in eeschema
Tnks
Marc


#6

I don’t think eeschema changed between 4.0.0rc2 and 4.0.7.

Change your grid size, as per @Rene_Poschl suggestion. I assume you can contact your friend by email, ask him what grid size he used? You might even agree to use the same settings.


#7

yes there is. Right click on any grid dot. The opening dialog has an option to change the grid. (It might be that you could even right click anywhere on the canvas. But i think for some versions you really need to right click on a grid dot.)


#8

It’s also in Preferences->Schematic Editor Options.


#9

Thanks to both of you

I’m using kicad for more than 10 years and never saw this feature.
with a smaller gridstep, the schematic will be messy… but usable

Thanks again

Marc


#10

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.