Component values showing in silk


#1

4.0.7 in Ubuntu 16.04. In the layout I have changed the value field in a few footprints to be visible in back silk. I look at the result in plot; pdf. The values do not show in the pdf. In pcbnew the text of the value is only visible if both value and bsilk is marked.

The dialog indicates to me that I have said to make the value a bsilk visible item. My problem is that most of similar footprints do not require a silk screen value; only a few do. I can do it manually, but the facility for what I want seems to be included. Is this a bug or am I not making the correct choices?

-Thanks


#2

Some changes were made in V5 that may affect your issue.
Recommend you update to V5 and see if you still have the complaint.


#3

Could you show screenshots of both the affected area of the pcb and of the plot dialog? (Should be possible in v4. Do not unnecessarily update to v5. Using v5 on old v4 projects is non trivial so i suggest a dual setup where you use v4 for old and v5 for new projects)


#4

I agree V5 is to be postponed.

I selected Footprint R14 on B cu; edit parameters; value edit: screenshot. Note that the layer is set to be back silk. The same layer was set for reference.

The same check of Footprint C8 shows the value layer to be B.Fab(not activated), as an example of the default setting for all footprints except for the 4 I want to show in b. silk.

Plot dialog screenshot: If plot values and plot references are not checked (as shown) the values and references of any footprints, including those set to back silk, do not show in the pdf. If the plot values and plot references are checked those items are shown for all footprints.

Will the gerber plots behave differently? ( I have not checked.)

As I said in my original posting I can manually insert the values for the 4 footprints I want show in the back silk, but I thought changing the layer in the footprint edit parameters should do what I want.

Thanks


#5

In the plot dialog enable “footprint references” and “footprint values”


#6

When I enabled them they showed on all footprints, regardless of the layer setting for values and reference for a particular footprint. I am trying to be selective as to which footprints show a value in b. silk.

Maybe the invisible attribute will accomplish what I want?


#7

When plotting you should get one file per layer. So if you have your values on the fab layer (as they are by default in the official lib) you will get them in the file for the fab layer. If you move them to the silk layer they will appear in the silk layer file. (if you disable the “plot values” thing they will not show up in any file.)

This means if you only move a few values to the silk layer only these will be in the silk layer file. (tested this in both 4.0.6 and 5.0.0)


4.0.6:

Silk pdf file:
Screenshot%20from%202018-08-10%2022-07-11

Used plot settings (for this test):


5.0.0

Silk pdf file
Screenshot%20from%202018-08-10%2022-16-53

Used plot settings (for this test)


#8

I sure feel that is what I did. I will do it again and document it click-by-click, but I thought the screen shot shows what I did. Plot showed values for all footprints or for no footprints in the pdf file for b.silk.


#9

Did you by any chance forget to safe before plotting?


#10

Well I do not know what I did wrong, but it works now. Maybe I should take up coffee drinking, or maybe knitting instead of PCB design. Thanks for your patience and help.