Component Path from other user

Hi all,

I’m new to Kicad from Eagle and am editing someone else’s file. Problem I’m having is that every time I try to do anything (edit schematic, edit footprints, create new components, ect) I get IO errors saying there is an issue with the path being inaccessible. The KISYSMOD paths in Libraries Wizard shows to be the kicad/modules cd on my computer. Is there something else that was supposed to be changed? How can I check to figure out which paths haven’t been updated?


It seems you don’t have write access to the files.
Is the project located on your pc?
Is it located in a folder where you have write access?
Can you edit the file with a texteditor? (Be careful what you do there, make a bacup before you try this.)
Do you get the error only when writing to a file or do you also get it when you open it?
(If it is the later one, do you have internet access? If not: the kicad standart libs are located online. You can make a local copy of them if you want.)

Editing footprints:
The footprints (and Symbols) that come with kicad are read only. (Stored on github)
You need to create your own libary at a location where you (and preferbly the other person) have write access.

Other possibiliby:
Did the other user create their own libs? Are these missing?

I’m kind of guessing here.

KiCad will tell you the path in the error window. There are several places where this path could be used:

  • KiCad Manager: Preferences -> Configure paths.
  • Eeschema: Preferences -> Component Libraries in “Component library files” or “User defined paths”.
  • Pcbnew: Preferences -> Footprint Libraries Manager on Global or Local table.

If the files have been copied from a CD , they may have the RO attribute set (read only).

All of the menus show the correct paths. I seem to have solved most of the issues, but now I’m running into another. I’m basically just exporting a dsn file then importing back a ses file and here is the error. It appears that it is searching elsewhere for the components?? Anyone have a clue what this is about?

PARSE_ERROR: Expecting ‘component_id’ in input/source
line 115
offset 14
from /Users/XXXXX/remoteroot/workspace/KiCadBuildMac4/kicad/common/dsnlexer.cpp : Expecting() : line 369
BOARD may be corrupted, do not save it.
Fix problem and try again.

Problem solved- the issue was actually that the component IDs have certain criteria. One of my terminal blocks was called “+1”.

I also thought that my project had been outsourced and thats why the user was showing ‘jenkins’. Learned a lot today