Clearance / design rules problem


#1

Hello!
I noticed a problem when routing manually. Kicad refuses to draw a trace from A11 (between DQ4 and A10).
There are many occurences of the same problem, Sometimes it work, sometimes not.
The grid is 0.125mm, the trace width is also 0.125mm and so is the clearance. So there should be space to
draw a trace between 2 traces. As there is just enough space, I suspect a software problem like this:
if(space <= clearance) {
dont_draw();
}
in this case, it falls exactly in the space == clearance, so it doesn’t draw.
Any idea on how to solve this? (except of course spacing lines a bit more).
I thought about giving some space by setting clearance not to 0.125, but to 0.124. But in this case,
there might be places with less than 0.125, which would violate the PCB maker rules.

And while we are at it, I just noted something else. I tried to set clearance to 0.124, but it doesn’t
change anything, it simply doesn’t draw. I also tried 0.1, same result. Is there any additional operation
to make the design rules valid for the current draewing? I suspect they are simply not yet valid.

Thanks for any hint.
Pascal


#2

Have you tried the shove router? It should nudge everything. If nothing else it might provide a clue as to why the software is balking.

Edit. All of he surrounding traces have the same clearance specifications?


#3

Hello!
Thanks for your reply!
Yes, I tried the shove option, but the result is a real mess. I would like to keep the vias where they are. As you can see, I like them aligned on the grid. If I use the shove option, all the vias will move to random places, not even on the grid. Is there an option to shove without moving vias? And even better, shove by keeping all wires on the grid?
Thanks!
Pascal


#4

[quote=“roboya, post:3, topic:9242”]
Yes, I tried the shove option, but the result is a real mess.
[/quote]The reason I suggested that option is to see if things got pushed all over. Something about your clearances doesn’t seem right. If you are using the stable version go back to legacy canvas and turn on the option to show clearances. That will show the clearances on all traces. It sounds like something isn’t set correctly for at least some of them.


#5

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.