Clearance around NC pin problem

Here’s a problem with the size of a no-connection pin. The board has a range of component pin spacings, from 0.5mm to 2.54mm. The default trace size is 0.28mm, and there’s a trace class “Thin” for use where needed.

Usually, pins get their clearance distance from the trace to which they are attached. But this device (footprint TO_SOT_Packages_SMD:SOT-353_SC-70-5) has a no-connect pin. Its clearance distance, taken from the default trace clearance, is too large, hitting pin 2. Is there some way to turn that down without changing the default everywhere?

Set default to the smaller value and all other nets that would have been default to the larger distance that you had for default?

That’s pretty much what I ended up doing. Changed 0.28mm clearance to 0.25mm clearance, and it clears.

I think you can also set clearances on a pad-by-pad basis, in the footprint editor.

I suppose the philosophically “correct” answer is that the global clearance should be set such that it is consistent with the smallest pitch parts to be used. Or, the parts’ pitch must be limited by the required clearance. In other words, if it’s not wise to have traces within, say, 0.28mm of each other, then it’s not wise to have pads that close, either.

Yet I have done several boards where I worked to clearance requirement that was wider than what could be achieved by the fine-pitch parts on the board. I did this by setting the global clearance to be consistent with the fine-pitch parts, then using my tri-focaled eyeballs to gauge the wider clearances. When the board was complete I ran DRC with the narrower clearance, then with wider clearances and noted where the violations happened. If the DRC squawks were confined to the footprints of fine-pitch parts, I was happy.