Changing track end style settings in Pcbnew? Square end traces supported?

The default tracks have rounded ends, but is it possible to have square or other style ends, without horrible hacks (e.g. using fills)


It is not possible to have other than “round segments” tracks. You have to draw it as zones. There are some ways that KiCad let you to import external draws to zones. (I am not an expert, maybe other can suggest how to import external draws and convert it to layers)

What is your use case of tracks with square ends?
Maybe others have solved the problem a different way and can chime in if they get to know your final goal?

if you see in the picture, I have a medium size track connected to a small pin. I don’t know if im being petty or even misguided, but I don’t like how the radius pokes out of the end of the pad.

Have you tried to neck down these tracks at the end?

@keruseykaryu just tried that, doesnt seem to affect

Personally I wouldn’t bother as long as there are no clearance issues. But if you create a custom track width, you can take the wide track to the edge of the pad, switch to a thinner custom track, and route to the centre of the pad to keep DRC happy.


I’m with @bobc on that one.

1 Like

There is a way to solve this, here is how I do it: trace with the width as much as possible before finish the track, then, (click) and switch to a smaller width to finish the connection. and voila.

Tanks @kammutierspule for workaround. I use it now non-stop in my layout.
This feature is actually needed quite often, and I believe proper Layout software should at least have it as option.
I understand it is easier to draw if everything is rounded to avoid “spikes” e.g. in case one trace connects to other trace in 45 degrees angle.
But option to change ending of some traces would be perfect.


Hey there!
Here is an example where the workaround of @bobc and @kammutierspule

1 Like

I’d say this case calls for a small fill zone to transition from the SMT pad to the thick trace. But give it a little bit of thought first . . . . will that thick trace, connected across the whole width, upset the thermal properties of the pad and lead to marginal solder joints on Pin 7? One or two very short, narrower traces (or thermal reliefs to a fill zone) may be in order here.


1 Like

I was about to start a fresh topic
“Wide Trace Extends back from pad”
However, I found this old thread.
The issue in post #4 (“radius pokes out”) describes my query - it seems better to continue this thread.

Related to this issue I also saw the following is the statement

We have a feature that’s internally called SmartPads. It tries to be smart about how a track exits a pad…

Is this feature implemented in Kicad 5 or is it still “internal”?

P.S. I have looked for “neckdown”, but have not yet found a menu setting etc relating to it. Changing track widths works reasonably but can be a bit fiddly.

The situation hasn’t changed. I’m not sure what that SmartPads is, but I’m sure it’s something different.

See the issue

BTW, add a thumb up in the issue database if a bug affects you.

@741 As a workaround you can use Taper footprints from my RF Tools repo