Changing package of a footprint

I have a problem and a question for you. How to keep footprint in place after changing package in the schematic? In Eagle, when I change the package size or a type, the footprint stays in the same place on the PCB where it was before. In KiCad it is different - often after changing the packaging, the footprint is outside the PCB area/edge and needs to be positioned. Can it be controlled or changed?

Thanks J

Change the footprint in the PCB first then use “Update Schematic from PCB” to get the new footprint into the Schematic.

To change footprint in PCB, right click on footprint, select properties, towards bottom RH corner click on “Change Footprint”.
This will only replace a footprint and keep it in the same position if the footprint anchors are the same.


Which is why the Library Standard requires the anchor to be at the geometric centre

1 Like

Yes, the Kicad library standard.

The OP is using an Imported Eagle Project… I was covering my posterior! :rofl:

Super, thanks a lot:)

Huh… here is the problem - some footprints loose their connection at all after changing, not every time, but most of them. Do you know why?

I never change a footprint of a symbol at schematic.
I remember that if I change symbol for the one having another footprint then after Update PCB from schematic I got new footprint at the same place as previous one. I decided to check if changing only footprint (without changing symbol) really moves footprint out of PCB.
My test (done at new PCB with currently all footprints outside PCB):

  • I have added a 1nF (0603) capacitor at schematic - it got reference C35,
  • I have updated PCB - C35 is outside PCB
  • I moved C35 inside PCB,
  • at schematic I have changed capacitor (adding new and deleting the old) to higher capacitance (1206) setting its reference to C35,
  • I updated PCB. Important is to have flag “Re-link footprints…on their reference…” set. Thanks to that KiCad can link new and old capacitors together (they have different time-stamp markings so KiCad will treat them as not being the same).
  • C35 footprint was changed without changing its position.
  • at schematic I have changed C35 footprint (have done it first time since 2017 when I started to use KiCad),
  • I updated PCB from schematic,
  • C35 footprint was changed without changing its position,
  • I deleted C35 from schematic, and from PCB to be sure that any symbol with changed footprint by chance won’t be saved in my schematic.

So I can’t confirm your problems. I use V 7.0.5.

Sorry, no.

This must be something to do with importing from Eagle. I have no experience with Eagle.
If they are both Kicad footprints (or one/both made in Kicad), one footprint will exactly replace a different footprint if the footprint anchor is in the same position. If the anchor is in a different position on the footprint, the footprint will not position exactly, however the ratlines will show where the pads should attach to the tracks.

I think the problem occurs with the Eagle imported project. This issue seems random. Resistors, eg. don’t loose their connections, but capacitors do.

KiCad generates for each symbol at schematic its unique identifier basen on time when it is added. I don’t know, and didn’t checked it but I suppose it is with 1s resolution. What happens during importing when lot of symbols are added in the same second… May be it is a source of problem.

1 Like

Anyway, I have solved this with some mixed solutions. A but by hand :wink:

1 Like

Please raise an issue with a sample so that the developers can improve Eagle import. You can make it confidential.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.