Changed to new pc, cannot see 3D models in 3D viewer

Hey there,

I switched to a new pc and tried to transfer my libraries and projects from my old pc.
The transfer worked, but if I open the pcbs from the projects (created on the old pc) I can not see the 3D models in the 3D viewer.

If I add a new component, the 3D model can be seen in the 3D viewer.

Does any one know a solution for this?


check your internal variables where they are pointing to, especially if the path of the 3D modules directory is correct

paths to the directory are correct, otherwise there won’t be a 3D model when I add a new component

Any other suggestions?

I think that’s normal because when you’re adding a 3Dmodel, you chose both the path and the model name. Note that this path/3Dmodel can be different from the 3Dmodel variable’s path. Then the path is stored in the PCB file to be called further.

The internal variables are a kind of relative path useful for pointing to the default directory where all the modules are in, whatever the absolute directory is. So when the pcb opens, it loads the modules from the stored path eventually containing the variable. If it differs from the configured one (Variable) or the specifically established one, it will find nothing. This why I’d suspect a difference in between the configured path and the PCB stored one.

I’d also suggest you to "E"dit a footprint and see what the 3Dmodel’s path is, compare it to the variable. Check as well that there’s no confusion between “-” and “_” and that there’s no space in the path. Think about the “/” and the reverted one if they are correctly applied to the libs.
If this doesn’t help you, unfortunately I don’t see any other clue for the moment.

You were right, the paths in the pcb file were still those from the old pc. I opened the pcb file with notepad++ and changed them with find and replace to the new paths. Just a one minute work.

Thank you very much for the tip, petra!

Happy you solved your problem. :grinning:

To prevent problems like these it is suggested to use path variables also for personal libraries as explained in Library management in KiCad version 5 and in the 3d model assignment section of Tutorial: How to make a footprint in KiCad 5.1.x?

Thanks for that great tip, Rene! It took me a while to get that working with the path variables. But I think, this will save me time, if a change to another pc sometime.

By the way, sorry for the late answer, I was busy with some other things.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.