Change line width in Kicad 8.x


Is there a way of changing the line width of a graphical object besides changing it for every segment seperately?

Also, can I define multiple lie width and change it on the fly while drawing?
I could have sworn there was a dropdown for this in previous versions…

the only setting i can find is the default line width, but I would like to be able to use more than one width on silkscreen layers.

1 Like

Edit > Edit Text and Graphic Properties

There is a bunch of stuff in this window that is worth exploring.
To make access easier the function can also be hotkey enabled.

1 Like

Use the property editor?

Also, can I define multiple lie width and change it on the fly while drawing?

  • defining multiple line width: I don’t know
  • change linewidth on the fly while drawing:
    • “E” hotkey during drawing opens the line properties dialog. You coul change the line width in this dialog and continue with drawing subsequent line segments. Note that the current line segment is ended at the position where you pressed the “E” key
    • CTRL plus “+” key: increase linewidth (by 0.1mm)
    • CTRL plus “-” key: decrease linewidth (by 0.1mm)
    • all mentioned hotkeys are for standard hotkey settings
  • a

I found this shortcut too. for some reason it does not work on and I have not yet found out why.


In the selection filter in the bottom RH corner, only tick Graphics.
Then, make a left to right selection box that contains the whole graphical object.
Then edit the value now showing in the Properties panel on the LHS.

Make sure only Graphics is ticked, because if there is something else inside the selection box, eg. text; poor Kicad gets confused and won’t show the editable width in the Properties Panel.

It seems you can pull this stunt with other things listed in the Selection Filter. I have successfully tried footprints, tracks, pads, text, vias & graphics. :slightly_smiling_face:

Note: this method only works if all the items in the selection and the Selection Filter are the same shape or width etc. If there are different thicknesses of track or graphics, or different shaped pads in the selection, Kicad says no.

1 Like

Its fairly typical that certain shortcuts don’t work on some international keyboard layouts. What keyboard layout do you have?

I use a US keyboard intl. layout. The problem might be that my left ctrl key does not work so I need to use the right one… other shortcuts with the ctrl key work just fine though. :person_shrugging: