Change layer transparency (solved)


#1

Hello there,
I am new to Kicad. I am trying to make the layers be 100% opaque. At the moment they are transparent:

How to change this transparency? I would appreciate all help.


#2

There is a button in the left toolbar… 3rd from the bottom, which causes what you see.


#3

Hi,
No that is high contrast mode. I mean to make the layer 100% non transparent. Look at the red layer, you can see the other layer on it, its transparent.

To be more clear- the pad on the screenshot is 0% transparent, how to get that for tracks?


#4

I’m not aware of such an option.

Might i ask for what usecase you need 100% opacity?
(In most cases it is useful to see where the tracks on other layers are.)


#5

as @Rene_Poschl says, this is not adjustable by some setting.
The tracks and pads are slightly different, so you can discern them.
Personally I even switch the pads into outline mode during layout, for even less distraction.


#6

I come from Altium Designer and Protel 99 SE long time before. I have used 100% opacity since I remember. Transparent layers just doesnt seem right for me- makes it harder to focus for me. Just thought of it as a standard option.


#7

It does not seem like one of us knows of such a feature. (In high contrast mode it does not seem that distracting to me. I mostly don’t even use the high contrast mode.)

You can always create a wishlist bug over at the bugtracker.
But be aware that feature requests without the support of a developer or a patch ready have a very low chance of being implemented.


#8

How can I make a Developer support me :P?

This seem like something of my concern: https://bugs.launchpad.net/kicad/+bug/991774
Isnt this aplha blending exacly this?


#9

I think this is about the legacy canvas. Just try out the legacy/default canvas and you will see how bad it can be.

In new nightly builds there is already a color selector that does allow you to select from the full range of colors. Maybe it would be possible to add an alpha canal slider to this as well. (I don’t have access to a new nightly maybe look into the new nightly before making a bug report. It might already exist there. If it does, i would suspect it could be found in the color selector for the layers.)


#10

From the same bug report:
Now, with OpenGL GAL in place you can modify alpha value per layer (shift + [ / ]). Still, there is no GUI to change setting, so I am keeping it in a wishlist.


#11

I think shift + [ ] does not work. In what version is it already implemented?


#12

I discovered that this does not work with my german key layout. I needed to switch to english layout.

It works in 4.0.2


#13

I had to click on the canvas for it to work… Great! Thanks :slight_smile:


#14

This is an interesting example of personal preferences and how the creative process works differently for each person. @bremenpl says the dim objects from other layers are distracting. I think they are useful, as a reminder of how the layer I am working on is integrated with other layers in the design.

Dale