Change default page layout and size

Hi all,

Is there a way to set default page layout (I have design file) and set certain page size for any new project?

I found some info on changing kicad.pro file but suggested lines does not exist in my file.

I am using latest KiCAD 5.1.9 version.

Sounds like you know how to change the page layout for a current project.

Next step is to create a custom Template and change the layout for it. Then, using this new template will use the specified layout in the template.

Not knowing your OS makes it a bit difficult to answer the question. Win, Linux and Mac have different locations for the config files.

And what would be the difference for this in this situation then?

Some time ago I did some experiments and it looks like the default page layout for new projects is hardcoded somewhere in KiCad.

Which brings you back to BlackCoffe’s suggestion of making a template.
A template is just a KiCad project copied to a special location (your own template folder) and then you add a bit of html as a description for your template and you add (or modify an existing) icon so you have something to click on in KiCad.

The extra stuff is pretty simple, just have a look at the default templates delivered with KiCad to see how (and what) is done.

I played with this as well and found out that the default layout is indeed hard-coded.
By just making a template, a new design will still load the default layout, so you have to load the template every time.
What I found out, is that by changing one of the configuration files, this can be changed so your own layout is loaded automatically. I’ve forgotten how I did it, though, so I’ll have to go back and look at it again.

I’m sorry, But, you’re wrong. It works perfectly well on my Mac and worked in all 5.1.x versions of Kicad. Just ensure the Paths are setup.

Example shows opening a new project from template and pointing out the Worksheet that gets loaded…

Could be. What irritated me immensely about the templates was, that they all were centered around existing projects like Arduino this and that or ST something.
I use KiCAD for my own projects and mostly the Eeschema part, so this is totally useless to me.
I like to open a clean project with MY schematic sheet layout. The existing templates can be put in the garbage can for all I care.

You can create your own templates. The Worksheet editor is useful for that and you can place most anything in it… And the process I posted enables user to move beyond those templates in the template panel… Thus, no Arduino related items need be present… Guess that’s why there’s a “User” template panel…

OK, went back through my attempts to get a custom page layout for Eeschema, and I now remember how it failed.

I’m running on Linux.

The normal way for an application running under Linux is to do the following:
1: look for a user layout under /home/[user]/.local/share/kicad/template/ - If not found:
2: look in /usr/share/kicad/template/ - If not found:
3: default to the hardcoded layout.

But KiCAD always defaults to the hardcoded layout. At least I’ve not been able to override it. This is a bug IMO.

Briefly… My power and internet are still down and not expected on for another week.
You can create a template folder anywhere and add it to the Path. Look into how…

EDIT: Power/Internet are back so, amending my brief post reply…

If you look at the link I posted and followed all the steps as described, it should work on Linux.

Ensure to follow all the steps including Quiting Kicad. And, pay attention to setting-up the Paths (snippet from the posted link).

It works for me and, though I could be mistaken, given the handful of ‘Likes’, I imagine others have had success and, no doubt, some use Linux.

@BlackCoffee:
Somehow we’re talking about two different things. Or perhaps not.

You keep mentioning templates.

I’m talking about Eeschema default sheet layout.

KICAD_USER_TEMPLATE_DIR is set for my layout. I’m not an idiot.
But no matter what I do, where I store my layout, whatever: KiCad loads the hardcoded layout every time.

There is no way to set a default worksheet other than using a project template at the moment.

Relevant feature request: https://gitlab.com/kicad/code/kicad/-/issues/5868

Well, I don’t know what I can say to help beyond what I’ve already posted and @craftyjon post underscores that Templates is the way it works.

Truly, not to suggest any shortcoming on your end but, consider starting from scratch and using the full steps I posted.
Also, I recommend Not putting your custom Template folder in any of Kicad’s folders. Place it in your Documents or other location, make sure you have Read & Write permission.

Vid below shows creating a New Project from a Template and opening Eeschema and pointing out the Legend on the sheet - it’s my custom worksheet. PCBnew and Eeschema use the SAME worksheet.

EDIT: Add screenshot of files/location. My worksheets, Template Folders…etc - all in one folder called “My_Templates” in my user directory. You can see the other related files…