Capacitors library lost

Hello,

Yet another rookie question. :slight_smile: I’ve done a project without problem and for the second one I’ve “lost” the capacitor library called from the schematic. I’ve also tried to add a capacitor in the old project but same problem, the capacitor library is no more in the list.

I’m sure I’ve done a big mistake but how to fix it? I’m on Ubuntu, I’m not allowed to delete a file, I think Ive killed a link or something like that. Is anybody aware of such a problem?

Which capacitor are you using and from which library?
Normally you should use the capacitors in the Device library.

The default libraries are read-only, so the chance you’ve accidentally deleted them is very small.

KiCad does not search for libraries. It only uses libraries listed in the library table, and there are a few of such tables. There is a system wide table for all the default libraries, and there is a “sym-lib-table” file for each project for project specific libraries. You can manage these files with: Eeschema / Preferences / Manage Symbol Libraries.

If you’re still stuck, then post more information such as library name and schematic symbol name, and also if you have only trouble with some capacitors or with all capacitors (& resistors).

2 Likes

Thanks Paul. That’s the kind of mistake I’m able to do. I was focused on a library called “Capacitors” or something like that. :slight_smile: You make my day.

Those plural names are always suspicious. It is a strong hint that you are using a footprint library from KiCad V4.

It also seems we’re writing about two different things. I was refering to a library for schematic symbols, while you apparently are having troubles with footprint libraries.

The current KiCad version is V5.1.10 and there are three default libraries for capacitor Footprints: “Capacitor_SMD”, “Capacitor_Tantalum_SMD” and “Capacitor_THT”.

No, shame on me, I had trouble with schematics.