Can't to open pcb - kikad asked me to install new version

hi.
i had installed kicad version 5.99 at 2019 and last time had refreshed it at july 2021. And some projects was created, and PCB too. And yesterday i had tried to open PCB, and get the error message


mean while, that PCB was created long before i refreshed this version.
and today i get installed the new version, but had get the same error message.

how to fix my pcb now to get open it?

and my version info is below, while i freshly installed it. and it’s icon is still remain in tray, while it’s absent in control panel/applications list.

Application: KiCad (32-bit)

Version: (5.99.0-11113-gc72914c43c), release build

Libraries:
wxWidgets 3.1.5
libcurl/7.74.0-DEV Schannel zlib/1.2.11

Platform: Windows 10 (build 19042), 64-bit edition, 64 bit, Little endian, wxMSW

Build Info:
Date: Jun 22 2021 09:03:27
wxWidgets: 3.1.5 (wchar_t,STL containers)
Boost: 1.75.0
OCC: 7.5.0
Curl: 7.74.0-DEV
ngspice: 34
Compiler: Visual C++ 1928 without C++ ABI

Build settings:
KICAD_USE_OCC=ON
KICAD_SPICE=ON

So why did you install an old nightly version?

Your version info shows:
Date: Jun 22 2021 09:03:27

While your KiCad screenshot shows:
image

The KiCad-nightly V5.99 versions are not stable by definition. Throughout this year the file formats have received version bumps about once a month on average.

So your best solution (usually) is to install the latest nightly. I do think though that today’s (or yesterday’s) nightly has a bit of an annoying bug, so maybe wait one or two days.

As an alternative, you can open the files of your project in a text editor and reset the date string at the top of the files to something older. The changes in the file format are usually very small, but note that even small changes can have significant consequences. For example, some time ago, the encoding of overbars was changed, and if you with file dates over that, then all the overbars in net labels and schematic symbol pins may be wrong, or if you’re totally out of luck KiCad may be unable to open your files at all.

I do not know why the latest file version bump was done. There is a header file on gitlab that names all KiCad versions and has a single line comment of what change was done.

i had installed yesterday version kicad-msvc.r24687.f2783a86e0-x86_64.exe
but the system info shows this.2

That commit is from 2021-10-12, so quite recent:
https://gitlab.com/kicad/code/kicad/-/commit/f2783a86e0d83accef360b2bd654f69a9e62cd35

And I don’t know why your version info then shows a version from June.

I’m confused by your message because the version you mention is the same which is shown in the screenshot below your text (with today’s date, 10/16/2021).

In https://kicad-downloads.s3.cern.ch/index.html?prefix=windows/nightly/ it’s the second latest version, with today’s date (in my time zone at least it’s still 16th of Oct). If you download and install the latest, does the problem persist?

I Think, that it will be all the same, because of info version shows that an old version is still installed, in spite of the new version installation had finished successful.