Can't store new footprint in library [read only error]

i have added a 3D Model to a part in the libarie. This worked fine as I could see in the 3D Viewer. When i wanted to store the new footprint, there is an error as shown in the picture.

Has it maybe somethimg to do with global and Project Specific Libaries? I didn’t really unterstand the differnce? Can anybody help me with this topic? I use version 5.1.2

You are trying to save to a system library. These are write protected as an update to kicad would overwrite your changes. Make a personal library to store your personal assets.

You might want to read:


Thanks, this helped me a lot. I tried the differnt things which were mentioned in the article. Now there came up a new problem, my schematic symbols and wireing went lost, mow it looks like the picture below.
At first I thought that I have deleted the part from the symbol Libary, but when I opened it with the Properties/Edit withLibaryEditor it opens the correct symbol:
Do you have any idea why this could happen?

Typically this indeed comes up when you renamed or deleted a symbol or library. (And when you somehow damaged the cache lib)
But there is a bug in some versions of kicad where it seems to not load libs properly after some actions. Simply close kicad and reopen the schematic that should fix it if it is indeed the bug.

1 Like

Seems to be a bug, a restart solved all problems

These were great articles. I have an annotation to

Using the library manager

If you configure “Path Substitutions” there are no Values Possible where
there is a gab in the Folder name. For example “Test Project”

Paths (or folders as you call it) with space characters in them are supported. (See screenshot, variable name TEST. I used that path variable to make a symbol library in version 5.1.2) What version are you on? What operating system? (There might be a bug)

Or do you mean the path variable name itself? This one can only have uppercase letters and kicad ensures you can only enter them this way. (Any other letter is ignored while creating your variable and you get an audio signal that you did something wrong.)

A tip: click into the path input field to reveal a browse button.

1 Like

I use version 5.1.2-1 and Windows 8.

I mean the path. It was someting like
home/Hallo Welt/test1/subtest
when i changed to
it worked fine.

I tried to reproduce the case(symbols):
If I configure the path this is shown:

nothing is substituted

Switch to 5.1.4.
As I understand that more then 100 bugs were fixed from 5.1.2 to 5.1.4.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.