Can't select and edit copper fill

Hi everyone,

for some reason, I cannot select copper filled areas anymore.

Usually (and this worked fine before) you can just click on the fill and then drag these white squares or circles around in order to modify the shape. I talking about this here (screenshot from youtube video https://www.youtube.com/watch?v=nPPDPVjin3M):
correct.PNG

Now, I suddenly can’t just select the fills. Also, when there is a bottom and a top layer copper fill right above each other, they’re shown in a golden color now. Before, either the bottom or the top layer was shown in red or green.

When I open the project on a different computer everything works fine, so it’s just about a setting in KiCAD, I guess - I just can’t find it.
Also, I tried to reinstall KiCAD, but nothing changed.

Does somebody know which setting this is, or is there something like setting everything in KiCAD back to default?

Thanks and best regards,
Florian

But first check if you have accidentally changed the toolkit, Preferences -> …Toolset… (should normally be Modern Accelerated).

EDIT: the legacy toolset both acts and looks different. Indeed, top and bottom zones together are blended so that they have a goldenish color.

1 Like

Yes, the toolset setting solved the problem - so simple.
Thanks for your help!

1 Like