Can't run cvpcb

Hi I’m new to KiCad, and finding it great so far. I’ve installed it on my Kubuntu system, created a schematic, bug checked it and exported the netlist. It won’t load into pcbnew because it hasn’t got the footprints.

There’s no button in the KiCad screen for loading cvpcb. When I try to run it from my start menu, I get this error message:

KDEInit could not launch ‘cvpcb’:
Could not open library ‘/usr/lib/x86_64-linux-gnu/libkdeinit5_cvpcb’.
Cannot load library /usr/lib/x86_64-linux-gnu/libkdeinit5_cvpcb: (/usr/lib/x86_64-linux-gnu/ cannot open shared object file: No such file or directory)

My Kubuntu is pu to date, and this is the info re KiCad:
Application: kicad
Version: 4.0.2+dfsg1-stable release build
wxWidgets: Version 3.0.2 (debug,wchar_t,compiler with C++ ABI 1009,GCC 5.3.1,wx containers,compatible with 2.8)
Platform: Linux 4.4.0-97-generic x86_64, 64 bit, Little endian, wxGTK
Boost version: 1.58.0

What to try from here?


That version is quite old. Isn’t Kubuntu taken from Ubuntu? I’m not sure why this would be so old.

1 Like

Hi Derek,
Version 4.0.2 is an old one. I can’t remember now whether cvpcb should be launched from eeschema (new versions) or from the kicad manager (old versions).

But for sure you can launch cvpcb from kicad.
See eeschema manual, section 2.8.

I work with kubuntu and I have both 4.0.7 and nightly build installed from the ppa.

1 Like

4.0.2 is quite old now. (release date February 2016) The current kicad release is 4.0.7. (I am not sure i would define this as up to date.)
According to the download page 4.0.7 should be available to you:

CvPcb is started from within eeschema not the main screen. (Under tools -> assign footprints or in your old kicad version it might be still called run CvPcb. Another option is to click the button in the top toolbar.)

I don’t think cvpcb is a standalone application in kicad 4. (It might have been pre version 4.)

1 Like

Thanks to all of you for the prompt and helpful responses. I upgraded to 4.07 and could launch successfully. I got a load of library-not-found error messages when I started cvpcb, and fixed these by changing the filenames in the Preferences -> Footprint Libraries page from eg Resistors_Throughhole.Pretty to Resistors_THT.Pretty etc (which is the name on my disk). Well on the way to cmpleting my first PCB design now!