Can't remap/recover Kicad 5 symbol libraries

So, I have a fresh install of Ubuntu 18.04, a fresh install of Kicad 5, and a clone of a project that I was working on in Kicad 5 on another computer. When I open the project on the new laptop, I find that all of my schematic symbols have been replaced with question marks.

When I first open the schematic in Eeschema, I get this window:


I choose the default option because I don’t have a custom library table saved from the last time I worked on this project. It only contains two custom symbols so this shouldn’t break ALL of them, I would hope!

Next, I get the below recovery dialogue… but it can’t figure out how to remap any of the symbols. (I’m really not sure why they need remapping anyway, nothing special is going on here and I have worked on this project in Kicad 5 before.)

Whether I click cancel or OK, the result is the same–a schematic entirely populated by question marks!

What I have tried:
– The suggestions in this post:
– Reinstalling the kicad libraries on the command line, then deleting and replacing them in the below dialogue

–Deleting the cache.lib and rescue.lib files from the project and sym-lib-table from ~/.config/kicad and re-opening the project in an attempt to “start from scratch”

No luck yet. Any suggestions appreciated!

1 Like

It looks like your project was rescued in the past. (before you atempted to transfer it over to version 5)

This means there should have been a library called beta_bms_rev1-rescue.lib in your project directory. Did you by any chance rename your project or delete this file?

That file does exist in the directory and the project name hasn’t been changed. The project was created in Kicad 4 but I did get it working in Kicad 5 previously, and the Git repo that I pulled it from should have had the latest Kicad 5 version of the project. I’m not sure what the origin of all the “rescue” stuff is.

check if the beta_bms_rev1-rescue lib is added to the local symbol library table of the project

Yes, it’s active under project-specific libraries.

The messages you get in the rescue dialog are quite strange. Normally the symbol name column should not include a library name. (So instead of “beta_bms_rev1:C” it should be only “C”) Could you share the schematic file?

They are really strange. Could I just open the .sch files and re-name all the symbols manually? Or is there a more graceful way to re-map manually? Here is one sheet:

cell_io.sch (44.6 KB)

Thanks for looking into this Rene!

could you also share the rescue lib?

beta_bms_rev1-rescue.lib (4.4 KB)

Is it possible that you somehow have a rescue lib that does not quite fit the schematic version? (You mention using git. Is it possible that somebody forgot to push something?)
For example the single pin connector symbol in the rescue lib is called Conn01x01 but the schematic expects it to be called Conn01x01-beta_bms_rev1-rescue (The first name looks like it is a rescue lib created by v5 but the later looks like the syntax of v4.)

Yep, opening the .sch files and removing every instance of “-beta_rev_rev1-rescue” at the end of a symbol name to agree with the rescue .lib fixed the problem. I have no idea how it got that way…but a Github SNAFU is a good bet. Thanks for your help!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.