Can't open any footprint in the footprint editor

I hereby certify that I am not simply asking someone else to design a footprint for me.

This is an auto-generated message that is in place on the “footprints” section of the forum. If I remove it and ask for a footprint to be designed anyway, I understand that I will be subject to forum members telling me to go design my own footprint or referring me to a 3rd party footprint site.

Recently I seem to have lost the ability to open footprints with the KiCA6 6.11 footprint editor.
I am trying to determine what might be going on.

When I double click on a footprint to open it, The line just flashes briefly and doesn’t open the footprint.

When I create a new footprint It gets created in the library I selected, but It won’t open either.

I’m on Linux mint 20.

Is there a log file for the footprint editor somewhere I can check?

Are you able to place footprints on your PCB layout from both Kicad and personal libraries?
When you create footprints, do you place them in a personal library.

Forgive me for mentioning these basics. I have no idea of how familiar you are with Kicad.

I have a footprint library with all of the footprints I had to create for various designs.

I tested placement of footprints. I can place parts from my personal library and the KiCAD libraries on the PCB. I just can’t open any footprint and edit it, be it in the personal or distributed libraries.

I can also see the parts display in the footprint browser if that helps.

You’re not trying to open the footprint from the desktop file browser are you? It should be opened in the footprint browser.

You can’t edit then save footprints in the Kicad libraries unless you first save them in a personal library but you should be able to do anything with footprints in personal libraries.

Does your symbol editor work?
Did the editors work in 6.0.10?

I moved from mint 20 to 21 a couple of weeks ago, but the footprint and symbol editors worked in 20 as well as 21.
Noticed you have 6.0.11. I’ve only used 6.0.10 and the nightlies. I’ll see if I can find a 6.0.11, download it and test.

Footprint editor is working in the just downloaded 6.0.11 on mint 21

Yes based on the info from the original poster, I think this is the most likely explanation. There is a good reason for this. If you edit symbols or footprints in the main libraries, they will be over-written when you update your KiCad installation. That would be very maddening, unless you had saved a backup.


I’m opening it from the footprint editor in pcbnew.

Hi Jmk,

Here are the answers to your questions:

Does your symbol editor work?

Yes. The schematic symbol editor works.

Did the editors work in 6.0.10?

No. The footprint editor stopped working with 6.0.10. I then tried upgrading to 6.0.11, and that did not resolve the issue.


Correct. This is why I have my own library

I resolved it. The slider for the footprint editor window was moved all the way to the right making the window invisible. Thanks for everyone’s help and suggestions.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.