Can't get "Copy Block" to work in library editor (SOLVED)


#1

I’ve used “Copy Block” plenty of times in the schematic editor, and it works great. You use the mouse to select a rectangular area, you right click and choose “Copy Block”, and then the new copy is selected and you can move it somewhere.

I tried using it in the library editor, and it works the same way, with the crucial difference that the new copy is not selected. I checked in the file, and it does indeed duplicate everything in the block, but there seems to be no way to separate the copy from the original. If I try to select the copy after the fact and move it, it selects and moves the original, too, so it doesn’t really do me any good.

Is there any way to duplicate and separate a block in the library editor? Or do I need to write a script to manipulate the file directly in order to accomplish this?

I’m using KiCad 4.0.7 on Mac OS X 10.9.5.


#2

when you move the selection and reach the intended target area, instead of left clicking to end the move, right click->copy block and observe what happens.


#3

Thanks, that seems to work! I wish there was more uniformity between the four tools (EESchema, library editor, PCBNew, footprint editor) rather than having to learn different ways of doing things in each.


#4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.