Can't find US8 Footprint, but it may exist

Hi,

I am trying to find a US8, which appears to be in Kicad somewhere:

I searched for it, but I still cannot find it. Any help would be appreciated.
Thank you.

Thank you, @Andy_P Andy_P : )

But it won’t load. Apparently, the .mod is “Not a footprint file.” I thought it was in the an older format, so I tried Legacy, but mods don’t show. There was an attempt to convert them, perhaps it wasn’t done right?

It’s confusing, because Kicad’s menuing suggests that Mod is current, but the webpage states it’s depricated.

" wallento Change footprints to new library format

Latest commit 474ed46 on Feb 15, 2016

History

The *.mod is deprecated, hence switch to new library format."

I tried cutting and pasting this (below) into a text file, named “US8.kicad_mod”
it doesn’t go, either.

In spite of my profound and deep-felt hatred of Kicad’s library management, perhaps the footprint creator broke the conversation. I will look for a legacy version.

Having failed, I might change the part with something with a more standard footprint.

[What a great way to destroy a ecosystem. It worked for Firefox’s XUL.]

Works for me. I followed the link, clicked on the raw tab to get to the text contents at this link:

https://raw.githubusercontent.com/myriadrf/component-libraries/474ed4658110161b9efc6f5bf20cc7385083ed54/KiCad/Universal.pretty/US8.kicad_mod

Then I downloaded it into my personal footprint library, opened the footprint editor, double clicked on USB, and got this:

Thank you, retiredfeline, perhaps it was the Notepad LF/CR that it didn’t like?

The footprint seems to be, now.

Shouldn’t matter I don’t think but I always use a URL downloader in preference to copying text from a window. Maybe you lost a closing ) or notepad added some extra stuff, who knows.

Just for fun:

  1. Follow the “show original” link in BrendaEM’s post to the file.
  2. Select and copy the file text.
  3. Create a new footprint in the KiCad Footprint Editor.
  4. Paste to the editor window.

For more fun: You even skip step 3.
You can copy the text from github, and then paste it directly in the PCB Editor.

Just for fun: What is your platform, and Kicad version?

It was Windows, KiCad 6.0.1 (yes, old).

LOL, how did I miss that, it was so obvious. Don’t all EDAs work this way? :smiley: