Can't figure out how to change Kicad 6 Ctrl+Click behavior (Ubuntu 20.04.3)

Hi there,

Long story, but I’d prefer to not have Ctrl+Click highlight a net. I’d rather have it remove items from selection.

According to Preferences → Editing Options, I could simply use Ctrl+Shift+Click to do this.

I can form this new habit if needed, but it’s more natural for me to deselect using Ctrl+Click. So I thought I’d try to change it.

When I look at my hotkey list (using Ctrl+F1), I see Ctrl+Click is indeed assigned to ‘highlight net’ - which is sort of what I was expecting.

I thought I could simply change it by going into Preferences → Hotkeys and reassigning it. But to my surprise, it’s not even listed there!

That’s when I noticed from the second screenshot that it’s actually listed under something called “Gestures”, rather than “PCB Editor”, etc. In other words, the option to change Gestures hotkeys doesn’t appear to be under Preferences → hotkeys.

So, anyone know how to change the Ctrl+Click behavior? Or what this thing called “Gestures” is?

Thanks!

Steve

P.S. If it matters, I’m on Ubuntu 20.04.3.

It can’t be changed in v6. Hopefully that will change in a future version.

The gestures section of the hotkey list appears to be for keyboard/mouse actions that are hardcoded/can’t be modified, but are nevertheless useful to include for reference in the full hotkey list.

Hey - thanks for clarifying this for me. Not the answer I was hoping for, but at least I’ve got closure.

Sounds like it’s time to form a new habit. :slight_smile:

Steve