Can't enter OPENGL mode--version issue


#1

I’ve haven’t used KiCad in a few years. My previous project was a huge success!

I have a new project in mind so I downloaded the newest KiCad version and installed it on my newly built custom PC using an ASUS Prime Z370-A motherboard. I decided to not go for a video card since I’m not a gamer. In any case, I saw some demos and was excited to try “shove” mode. I tried to enter OPENGL mode and I got an error message that I need version 2.1 or higher. I checked and I have version 1.1.

I don’t think I can update OPENGL for my motherboard. At least I couldn’t fine a way. Other than adding a video card, is there a way to get into OPENGL mode? Any suggestions?


#2

The cairo canvas should give the same features as the opengl one but without the need for hardware acceleration. (It might be slower for some operations. You might even experience lag.)

More details see the FAQ entry about the meaning of canvas options


#3

The Z370 should support OpenGL 4.5
Take a look at https://www.intel.sg/content/www/xa/en/support/articles/000005575/graphics-drivers.html


#4

Thanks, David. That link got me to the right place to upgrade my video drivers. Now, I have OPENGL 4.4 (partial 4.5) installed and the mode works great!:thumbsup:


#5

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.